Can't export retargeted animation sequence

Hi, I’ve retargeted an animation sequence to another mesh, and that has created a copy of the original sequence and adapted the new to the specified mesh. However, when clicking Export after right-clicking the new AnimSeq it brings my directories in a window, I choose a folder and click save, but nothing gets saved. Why? And how to actually export it?

Hi Albert,

I tried this with a retargeted animation on my local machine and it generated an .fbx with the correct skeleton and animation data; so, there must be something going on in your particular situation. You’re able to export non-retargeted animations? Also, do you mind trying it with different assets, as in exporting a different animation that was retargeted onto a different skeleton?


Hi Ray, thanks for answering. I’m able to export non-retargeted animations with the Export button, but when doing so on any retargeted animation I’ve tried it doesn’t give any errors and apparently saves the file, but no .fbx file is truly saved in the specified folder.

Man, that is really weird. Did you try to export any other retargeted assets? Especially ones retargeted to a different skeleton than the one you’ve been using? In the meantime, I’ll forward this to one of the animation programmers.

Hi again, it’s funny because now I’ve exported a non-retargeted animation first, and then tried to export one that is retargeted but with the same name of the first one, it has asked me if I wanted to overwrite the file, and the export has worked now.

Hey Albert. I’m gonna mark this as answered, but if this pops up as an issue for you again, just yell.

OK, that’s fine.

Happens to me on retargeted animation skeleton, from time to time for some unknown reason.

I had to change the target back to the original skeleton to be able to export. But it worked.