Can't download unreal engine?

I just tried to download unreal engine 5.1, but it cancelled because I didn’t have enough storage. I just uninstalled a bunch of games and now have 250+ GB of open storage, but I still can’t install it. clicking the button does nothing, clicking the arrow does nothing except open a menu that does nothing. I’ve never used unreal engine before or this community thing, so tell me if I did something wrong. Attached is an image.

Hey @Derpygamer243598!

SO I know it sounds silly, but restart your Epic Games Browser. Close it out completely.
Once you start it up again, if that doesn’t work, empty your recycle bin and restart your PC (We’re trying to clear caches here) :slight_smile:

Thank you for answering, I tried that just now, but it didn’t work. I could try uninstalling the Epic Games launcher and reinstalling it, but I don’t want to do that if it might not work because I always have trouble logging in. Do you think it would help? Thank you!

I would definitely give that a shot!
What keeps you from being able to log in easily? I might be able to help with that!

Basically, I have my xbox set up with my xbox credentials. The epic games launcher doesn’t like when I try to log in with those, so I made a second account. The username is really long and complicated, and it takes me forever to find where I wrote down the login credentials.