Can't download UE

How do you download Unreal Engine? No, seriously. When I click on DOWNLOAD, it takes me to an account creation page. Logging in on the forums works, but when I click on Download, it logs me out, then takes me to the account creation page. I can only log in from the forums. Trying to log in from any other page fails. I was able to download and install it in Virtual Box, so why can’t I download it on my regular Windows system?

I’ve tried using Basilisk, Edge, and IE, and it won’t let me log in and dl it using any of them.

Run Epic Games Launcher, log in, go to Unreal Engine tab -> Library -> add desired engine version.

Does it help?

I think he’s trying to acquire the launcher itself given his attempts to download via the site. Try this link and see if it works - Download - Unreal Engine

Thanks, that let me download it. However, it still logged me out.

The other day when I looked at the download button in the upper corner it seemed to be linking to the register page. It appears to be fixed now though. At any rate you should be bale to install and login to the launcher without issues. =)

I think you need an account. When I tried to save anything in an unreal engine a month ago, it gave me “unknown error” when i was logged off without account.