Download

Can't download source from Git Hub

I am trying to download the source version of Unreal from GitHub. I have followed a tutorial on the unreal site. I have made a GitHub account, verified my email, copied it into the GitHub account name on the connected account on my Unreal account, and have received an email that says my epic account is connected to GitHub. I have not received the email to join epic on GitHub, and have no badge. Does anyone have an idea what I can do to fix this?

I’m having this same exact issue as well.

exact same issue here

Do you see the EpicGames organization like in the screenshot in your GitHub profile?

Continuing the topic! I connected a GitHub account to my account on Epic Games, but I did not get access to the page of GitHub UE4!

I do not have!

Same problem here.

I have the same problem and i connected my github account to epic account but still doesn’t work and don’t appaear the Epic Games organizations on my github profile .

having the same problem

I solved the problem. All you need to do is:

  1. Uncheck “Keep my email address private” in GitHub account settings.
  2. Reconnect you GitHub account in UE
  3. Get the email from GitHub and follow the instructions.

If the above does not work then proceed with the following modification after step 1
2) Change Email Preferences to “Receive all emails, except those I unsubscribe from.”
3) Fork the open EpicGames/Signup Repository to help establish a link.
4) Reconnect your GitHub account in UE [Note the above fork will remain active throughout the process]
5) Get the email from GitHub which simply says that you have successfully added GitHub association to your Epic Games account and does not have instructions.

I have the same problem.

@Edit
I got the invitation 4h ago, i see the invitation only when I’m on the EpicGames github.

I had the same issue but it was my own stupidity so just posting in case anyone has done this. The invite from GitHub goes only to you primary email address that is set in Account Settings. I was checking another email. Dumb I know. Sorted now,

Unfortunately I have the same problem. Set the e-mail settings as advised. And both accounts have the same mailaddress :slight_smile: