Can't download new UE version with Student License

Yesterday I activated a key that I got from my university to get a one year subscription. I got the confirmation and the subscription plan now lists as “No Charge + 5%”, however I cannot download the preview or any of the old builds now. They all have a “Subscribe” button that redirects me to the registration page.

What should I do?


It sounds like you are having a Launcher error in that case. I have assigned a technician to look into the problem.

If we are unable to reproduce the issue, or we need additional information, our staff member will comment here with additional questions. Otherwise, we will post an ‘Answer’ once we have logged the issue in our bug database or we have a solution for it.

In the meantime, please be sure to review our suggestions for how to report a bug, and feel free to edit your post if you have additional information to provide.

Thank you.


After going through the steps provided, try restarting the Launcher if you haven’t already.

Then try the troubleshooting steps linked below. Afterwards if the issue is still present, follow the steps at the bottom of the page to find your ‘Verbose Logs’ and post them here. They will help us track down the issue.



Hi TJ,

none of the suggested things worked, also when I tried my account from work it worked without problems on the same computer so my guess is that it has to be something on the account side. Here is the log


I checked your account and it seems whatever code you attempted to redeem did not activate. Please try to activate your code again. To do this, hit the subscribe button and sign in from the registration page and select that you have a code. Enter your code and if you receive any errors, let us know. If it worked correctly, it should give you a clear message and you’ll receive an e-mail as well.


Hi ,

I tried it and and it says “Sorry, that code has already been redeemed.” and it also states that my current subscription plan is “No Charge + 5%”


It seems somebody gave you a code already in use by somebody else. Where did you get the code from? Somebody from your school or perhaps GitHub? They may accidentally given out the code twice and you should ask them for another.

Alternatively, try contacting our customer service at and they may be able to help. Please include the code in the e-mail and they would be able to confirm.

As I said in the beginning, the first time I used it I got a confirmation which enabled the subscription plan you see on the right, but now it doesn’t work anymore and the launcher doesn’t seem to recognize the plan.

I got this code from my professor and at the time it worked just fine. I will email the customer service.

Got it. If you received the confirmation, it’s likely there was an error in our system and the code was burned without giving you access (which we have seen happen to a handful of folk). CS has tools to be able to confirm. Sorry for the problem and let me know if you need further help.