Can't do a simple asset move to folder


Hi, cant move an item in content browser to a new folder.
Trying with a new created asset without any references and when I try to move to new location, nothing happens.


Hi ,

I have found a workaround and the exact conditions: The Move/Copy dialog only appears when View Type is “Tiles”.

Answering your questions:

  1. I can’t move anything, only create and delete.
  2. I think Issue started now with 4.8.3
  3. Tried with brand new clean projects: “Rolling” and “2D Side Scroller”.
  4. Nothing changes.

Repro steps are very simple:

  • Create/Open new project.
  • Select content browser View Type to List View or Columns View.
  • Create new folder
  • Create any asset (2D sprite or Physical Material)
  • Try drag the assets over the newly created folder. (Nothing happens)
  • Try to save the assets, nothing yet.
  • Change View Type to Tiles. It works!


Hi piXelicidio,

I’ve tried recreating the issue of not being able to move a newly created asset with a number of projects (Specifically, the “ball” Physical Material) and it moves -or copies- to other directories without any problem.

  1. Are you able to move other assets?
  2. Did this just start with 4.8.3 or was this it this way before.
  3. Have you tried this with a brand new Project or does this only occur in your current project?
  4. Have you tried saving and reloading the project?

Please try this in a new project and let us know if this still occurs. If so, please provide precise repro steps so we can better try to recreate the bug on our end.



If anyone is having this same issue set your content browser view type to “Tiles”, then it works.

  • Or drag the item to the folder tree instead of the folder in the same list.

His piXelicdio

Thanks for posting your workaround for other users who may be experiencing this issue. However, I cannot enter it as a bug as I am not able to reproduce the issue, just following your steps:

Can you send provide your dxdiag so we can test this on a more similar machine?

Sure, here it is… link text

Wait… found something new. If I drag the item like you, to the folder tree it works. But if I drag the item over the folder in the same list, it don’t work.

Thanks for the clarification. I’ve tested this in 4.7 and 4.8 and I can shift these in the “list” view (pictured below) but not the “column” view (pictured above):

This is expected behavior. Is this not the same for you?

I the List view of your last image, if I try to drag “BallTest” over “RollingBP” above “BallTest” then I see that box “Move or copy “BallTest””, but when I release the mouse nothing happens (There is no Copy Here, Move Here, after that).
If this is a expected behavior why showing the “Move or copy” box?

You are correct (I’m used to that pop-up working). This is indeed a bug where it works in tile view, you get a pop-up that does not work in list view, and in column view, there is no pop-up and you cannot move or copy the asset. I have reported this as JIRA [UE-19914]. When this is corrected, we will update this post.

Thanks for your patience getting this straightened out.

Hi piXelicidio,

This has been fixed for a near-future release of the engine. Thanks again for pointing this out!

Great! UE4 team are awesome! :slight_smile:

The answer may be that your files are marked read only. I discovered this after removing a project from source control.

This is it piXelicidio. Thanks!