Can't delete certain files in UE4 editor 4.22 (assertion failed)

Hey there. Thanks for viewing my question. I have been working with Ue4 for a while now and suddenly near the end of a project i am working on, it has begun crashing a lot which i intend to ask about in another question. During the time it started crashing a lot I noticed there were some leftover assets from a project I imported from the Marketplace that have been sitting there for a while. When I try to delete them I get the message:

World /Game/AdvancedMagicFX08/Maps/Overview.Overview is in use.

Running the editor with ‘-NoLoadStartupPackages’ may help if the object is loaded at startup.

External referencers of World /Game/AdvancedMagicFX08/Maps/Overview.Overview:
GCObjectReferencer /Engine/Transient.GCObjectReferencer_0 (root) (28)
0) [[native reference]]
1) [[native reference]]
2) [[native reference]]
3) [[native reference]]
4) [[native reference]]
5) [[native reference]]
6) [[native reference]]
7) [[native reference]]
8) [[native reference]]
9) [[native reference]]
10) [[native reference]]
11) [[native reference]]
12) [[native reference]]
13) [[native reference]]
14) [[native reference]]
15) [[native reference]]
16) [[native reference]]
17) [[native reference]]
18) [[native reference]]
19) [[native reference]]
20) [[native reference]]
21) [[native reference]]
22) [[native reference]]
23) [[native reference]]
24) [[native reference]]
25) [[native reference]]
26) [[native reference]]
27) [[native reference]]

Shortest reachability from root to World /Game/AdvancedMagicFX08/Maps/Overview.Overview:
World /Game/AdvancedMagicFX08/Maps/Overview.Overview [target] (standalone)

This is the error I have been getting in case it may have any accordance, because when I try deleting the files through Windows Explorer I get the same crash every single time when starting up the project.

Assertion failed: [File:D:\Build++UE4\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 249] Result failed at D:\Build++UE4\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Viewport.cpp:361 with error E_INVALIDARG

Thank you for your time.

Had exactly the same problem deleting some maps.
In Windows10 I went to the root folder of my project, wrote cmd in the top textbox so It opened a command prompt at my root projects folder. Used “XXXXX.uproject -NoLoadStartupPackages” to open my project with that flag.

Then you can remove those files with no warnings or any other problems.
At least this worked for me.

I know its so late but until today I havent seen this warning ahead.

I’m having exactly the same problem trying to delete a map - running the editor with the -NoLoadStartupPackages flag has not worked for me - this is really weird.

Do you have any other ideas?