Can't create C++ in Unreal Engine 5

Hello, i downloaded the UE5 EA a few days ago and wante to start playing arround with it, i noticed that i all of the sudden with the UE5 i can’t create C++ projects anymmore and it allway gives me this error

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/UE_5.0EA/Engine/Binaries/DotNET/UnrealBuildTool/UnrealBuildTool.exe -projectfiles -project=“C:/Users/ziva1/Documents/Unreal Projects/MyProject2/MyProject2.uproject” -game -rocket -progress
It was not possible to find any compatible framework version
The specified framework ‘Microsoft.NETCore.App’, version ‘3.1.0’ was not found.


Which is weird since i have all the NET frames installed and i worked on C++ before with UE4.26

I tried diffrent NET frames now from 3.1.0 all up to 6.0.0 preview nothing works

Blueprint projects work perfectly fine tho what i also noticed i can’t import an Assets from the marketplace into an UE5 project.

Can anyone help me out here?

1 Like

Here is my tutorial on the subject :slight_smile: