Download

Can't connect Android device to PC

Hey, I’m trying to get my Android to run on my computer and run my unreal engine project and I can’t get it to work. I downloaded Code Works and did all of the steps the Unreal Engine Documentation said to do but when I hold the windows key + R and type for to open command prompt I then search adbdevices and my Android never shows up even though it is connected to my computer. I was reading on the internet that it may have to do with a driver that doesn’t come with my pc. Can someone help clarify what is wrong? Thanks? :relaxed:

Someone said I need to jailbreak my android device. Is that nessisary?

Hi there.

First - not adbdevices but adb devices, but I assume it was a typo :wink:

  1. From Android SDK Manager make sure you’ve installed “Google USB Driver” from Extras.
  2. On the device You must enable the developer mode, You do this by tapping few times on Build Number in Settings->About Phone. (http://www.greenbot.com/article/2457986/how-to-enable-developer-options-on-your-android-phone-or-tablet.html).
  3. When you enable developer mode go to the developer options and enable USB Debugging option.
  4. Connect Device to PC. Windows should install some extra drivers. Android should ask about giving PC permission to connect to the phone. If not, you might try to disconnect and connect device again.
  5. If it won’t work… some devices requires extra drivers. Try ADB Driver Downloader: http://adbdriver.com/ but only as a last resort.

Hope it will help :slight_smile:

Hey,

Sorry it was a typo lol.
I checked my SDK Manager & I actually didn’t have Google USB Driver installed. So I installed it after it completed I restarted my computer and went on my Android and set Developer mode and enabled the USB Debugging option.
I then connected my device to my PC and my computer made a noise alerting me something was plugged in but it never installed any drivers also my Android never asked about giving my PC permission to it’s self.
There is a image of a prompt I did and what the results were. adbhelp.png

Quick heads up. In the UE4 Docs it said to get CodeWorks for Android 1R6 but I got 1R5 because it was the only option and wouldn’t display any higher version. I’m not sure if it matters or not lol

Thank you for your assistance! :slight_smile:

The version of CodeWorks affects the libraries used for building, not the connection. But you should have 1R5 anyway, to build anything in Unreal for Android :wink:

There is also one more thing - if your device is connected in PTP mode (photo sending) it might not detect it by adb.

I also recommend the ADBDriver downloader. I know that some models of Samsung Galaxy has fancy drivers… What device model do you have?

Hey,

Its a LG phoenix 3. OS Ver 6.0.1 .
Also its in MTP mode.

Thank you for your help :slight_smile:

Installing a ADB Driver manually seems to be a bit dangerous. What do you think?

Naaah, why do you think so? It’s a normal driver like any other one.

Okay I will try that. :slight_smile: Also do you think by the type of phone I have, it does sound like I need an ADB Driver installed?

I tried to install the Driver into my computer and it gave me this very odd error. My computer is an Alienware Windows 8.1 .

adbie.png Thanks!

There always must be an Android device, that will make troubles out of nothing…

I was working with several models at the same time and some of them were really annoying. I was uninstalling and installing drivers all the time.

Unfortunatelly - I’m out of ideas. Only thing that left is to try to install drivers from the manufacturer, try here http://www.lg.com/in/support/software-firmware

Good luck!

MIght sound weird but have you tried using a different Usb Cable some phones refuse to connect to a PC with certain cables its worth a try. or if your device is using usb-c try flipping the cable some cheaper cords have the data line setup weird were it only works one way

Ok, Thank you Zompi for the time you have taken to try to help me out. :slight_smile:

I have been using the default USB that came with the phone but I’ll try your suggestion. Thanks :slight_smile:

I tried everything on forum pages and found a simple solution with the USB Connection type. As soon as I changed it to PTP and enable USB Debugging option enabled it recognized in a second.Thank you Zompi2 :slight_smile: