Can't Compile C++ Project, needs windows.h

Using 4.3.1 Version, and when compiling the C++ project, I get the error:

error RC1015: cannot open include file ‘windows.h’.
error C1083: Cannot open include file: ‘new’: No such file or directory

Hi Kevin,

Please download the attached file and place it in an empty folder on your desktop, then follow these steps:

  1. Remove the .txt extension from the end of the file name.
  2. Run the batch file. It will create a new file inside the folder named info.txt.
  3. Upload that file back here.

Hi Kevin,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

I have the exact same problems, and it seems it’s due to the fact that my Windows user name contains some special characters (I’m French speaker) that are not supported by the compilation variables of UE 4… which is very very embarrassing for many UE developers from outside the US!

link text

I’ve created another Windows account on the same machine, w/o any special character, and the compilation is working now.

Hi ,

I am glad that things appear to be working fine for you now. We are working on finding a way to get around the limitation on special characters in file paths. Unfortunately I really cannot say when, or even if, we will be able to support that.

I’m having the same problem. My username on my computer containes only regular letters, so that can’t be the problem. I tried what you suggested and got this output:

link text

Hi Skrox,

What version of Visual Studio 2013 are you using? Do you have any other versions of Visual Studio currently installed?

It is a bit odd that your VS120COMNTOOLS Environment Variable appears to be set correctly, yet an error is provided saying that the batch file cannot locate the common tools folder. I also noticed that the PATH, INCLUDE, and LIB values appear to be missing a lot of entries related to Visual Studio (when compared to the results I receive from the batch file).

I have a few suggestions for you to try:

  1. Some users have reported that they received error code RC1015 because their antivirus software mistakenly flags some necessary Engine files as malicious and quarantines them. Try temporarily disabling your antivirus software and build again.
  2. Another, more common, cause for receiving error code RC1015 and C1083 is because the Microsoft Windows SDK isn’t installed, or was installed incorrectly. Make sure you have downloaded the correct SDK ( or Windows 8) and have it installed.
  3. Lastly try reinstalling Visual Studio.

Since my first post I have reinstalled visual studio (I’m using 2013 ultimate), as well as disabled my anti-virus. I’m still getting the errors. I believe the problem is coming from an error in my windows SDK. I have tried to reinstall it, but it gives me the following error:
A problem occurred while installing selected Windows SDK components.

Installation of the "Microsoft Windows SDK for " product has reported the following error: Please refer to Samples\Setup\HTML\ConfigDetails.htm document for further information.

Please attempt to resolve the problem and then start Windows SDK setup again. If you continue to have problems with this issue, please visit the SDK team support page at

Click the View Log button to review the installation log.
To exit, click Finish.

link text

The referred file ConfigDetails.htm doesn’t exist.

Edit 1: I have since figured out the problem with my sdk installation. I was receiving error 5100, which you get when you have a newer version of visual c++ redistributable than the one being installed by the sdk. I eventually figured out that the reason I didn’t catch this earlier, was because there had been some sort of error when I first uninstalled it, and it was still on my computer and I couldn’t see it. I used a program from microsoft to fix ms products that don’t install/uninstall properly. As of right now, i’m running the sdk installer again.

Edit 2: Windows sdk successfully installed. Attempted to create a c++ project in UE4; was able to get further into the the project creation before it game me an error (it got past generating code and got to compiling where it froze at 9%, followed by a “program not responding” message, then an unreal engine error.) I’m now no longer getting the windows.h error, but now i’m getting the “Cannot open include file: ‘new’” error.

Hi Skrox,

Is this still an issue for you? The error codes RC1015 (cannot open include file ‘windows.h’) and C1083 (Cannot open include file: ‘new’) usually come in together, and our known fix for those errors is to make sure the Windows SDK is installed. Since you have already done that, we need to look at other possibilities. Would you mind running the get_vs_environment batch file again and post the results?

Reran the .bat and this is the new file it produces.

link text

Edit: I tried creating a new project again and this time going to the VC++ Directories and changing Include directories to inherit from parent or project defaults. After doing that and trying to build the project, it again produced an error c1083, but referencing windows.h from RC1015:

c:\program files\epic games\4.8\engine\source\runtime\core\public\Windows/MinWindows.h(62): fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory

As far as I can see now, there is no file ‘new’ error, but its a bit wierd how it is referencing windows.h and calling it error c1083 instead of RC1015

So just some thoughts on why it might be telling everyone that it can’t find the file windows.h in the directory C:\program files\epic games\4.8\engine\source\runtime\core\public\Windows … I checked that directory and sure enough, there is no windows.h file there. So could someone who has an actual functioning install of ue4 upload a copy of windows.h for us?

The Windows.h file shouldn’t be located in the Engine’s source code. In my case, the Windows.h file is located at C:\Program Files (x86)\Windows Kits\8.1\Include\um

I am still a bit concerned that the INCLUDE field in the Info file you provided are blank. For comparison, this is the file that I get when running the batch file. Note that the INCLUDE and LIB fields both have entries, and in my case the INCLUDE field contains the location where the Windows.h file is found. I am going to do some checking to find out if there is a way to manually set these fields.

I have a couple things for you to try and let me know the results.

First, try creating and building a new, non-UE4 project in Visual Studio. Does this build successfully? If so, add a #include "Windows.h" line to a header file and try building again. Does it still build successfully?

Secondly, locate and run vcvars32.bat (located in ..\Microsoft Visual Studio 12.0\VC\bin\). Does this complete successfully (a Windows console window will appear and then disappear), or does it display an error message? Do the same with vcvars64.bat (located in ..\Microsoft Visual Studio 12.0\VC\bin\amd64).

The line in your info file that states ERROR: Cannot determine the location of the VS Common Tools folder. seems to actually be coming from the vcvars batch files.