Can't compile blueprint, no error


I have a weird problem with the a blueprints lately. There were different symptoms.

First, when compiling my blueprint A, the blueprint B became “dirty” (indication that I need to compile it again), and when compiling the blueprint B, it’s the blueprint A that became dirty and so on.

I ignored that because I still could work on my project and test stuff, but then the Editor started crashing when I wanted to compile. Still it was pretty random (but very recurrent), so I continued working, saving often and praying for the program not to crash.

But now there is a real problem, I can’t even compile my blueprint anymore. When I click on it, the icon stays “dirty”, like if I didn’t compile it. It doesn’t find any error, and when I want to test my level, there is the warning that there are still errors in this blueprint. The behavior in-game of that blueprint is also really weird, I suppose because it wasn’t completely compiled or something like that.

It’s a relatively complicated blueprint and I really don’t know where the problem comes from so I don’t know if it makes sense to post it. All I can say is that when the problem started to occur, I was doing stuff with a lot of references of other blueprints…

Please help me, I can’t work on my project at all.

I remember something similar happening. It was an error with a reference which would change something in another blueprint (a node) but this would then again do the same in the first one catching you in an infinite loop or something like that though I can’t remember exactly what it was.

Could you show us the blueprints if they are not too large so we can take a look at what might be going wrong there?

Thank you for your answer, you are probably right. I can’t show you the entire blueprint though, there are too many functions and stuff. But most of the times it looks like this (loops, a lot of casting, references…):

The blueprint has 5 children blueprints. The compiling problem occur for them as well. References to other blueprints are stored in variables, maybe somewhere there is an infinite loop like you said.

I will take a closer look tomorrow and let you know if I solved it.

Okay I found it. One particular child blueprint was always crashing when I compiled it. It had one variable for itself that I called in the parent blueprint after a casting like so:

(pion_BP is the child blueprint)

I deleted the variable from the child blueprint and deleted that casting and stuff for now, now it’s compiling. Still how am I supposed to access a child’s variable from a parent blueprint?

You don’t.

There is no reason and nothing you should ever do in your parent class which involves functions or variables from the child.

If you need a variable in every instance not just that specific child add it to the parent one.

Otherwise do it in your child Class.

Of course, thank you.

Solved then!