Download

Can't commit multi-line input box on Enter

Even when explicitly setting the commit method to On Enter, hitting Enter in-game just adds a newline to the textbox. 4.15.0

cantsaveinput.png

Sounds intended. Can’t think of even web pages that would allow commit in a text box for return…

Maybe you mean this:

https://answers.unrealengine.com/questions/258732/how-to-commit-text-on-a-multi-line-textbox.html

Tried that- got into the weeds trying to work out what wasn’t shown re. how to actually handle the Enter key event (meaning I was able to override preview key down to prevent catching Enter, but couldn’t figure out how to handle it manually).

And Commit on Enter is the standard on, for example, Facebook; you have to use Shift-Enter to over-ride that behavior. Not saying the UX on Facebook is right, just that there are well known web based examples of Commit on Enter for multi-line input.

<edit> not trying to be pedantic, though: I do appreciate the help :wink: </edit>

And, more to the point, if Enter doesn’t commit, what does, by default? The only connection that worked was On User Moved Focus.

Hmm I’m not at my computer to look but in web coding there is a difference between text area and text box with multiline ticked. I know what you mean tho I’ll keep digging on this in curious as well now