Can't click on buttons on Android

Well, i complete the entire mobile setup to play my project on Android, but when i try to play it i can’t press any buttons, the UI doesn’t work. The same happens in the android previewer PIE.
I found a guy with the same problem as me, but it was classified as an engine bug in 2017, and it doesn’t have a fix to the date, i tried everything, un-checking “is focusable”, uninstalling and installing the engine, nothing works.

The input mode is set to UI only, but gameplay and UI doesn’t work either.
Link to the another post:


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


Well, i submitted the bug.
Any idea of what to do?

I strogle with the same problem on UE5, but I think this is not an bug, looks more like some settings are missing. I say that because I used top-down example project, and I set an basic UI with an exit button and worked fine. The problem come when I started an blank project. I will search to compare this to projects and I will come back with the solution if I found it.

I found that virtual joystick cause the problem in my case. Look’s like is rendering on top of everything and for that reason the buttons can not be pressed. So I disable the touch interface and I will use one from the marketplace.

You can do a virtual joystick for your self if you want, is just a pure math for clamping the position over all. To move an image you will need to override a widget function like that.


Or you can use Ultimate Touch Components. For me was fine at the beginning, but after a while on PC simulation was not working the joysticks any more, but on android device I had no problems with this one.
If you want to use it be aware is a project base, not a plugin. So you will need to migrate the UTC files to your project.

i package actionRPG as apk. it works well at first . after i move forward may be 300 meters. the joystick still works well, but the attack button can’t work. and when i move back it works well again . is the problem same with yours?