Can't click menus on mac

Please see attached video. Attempting to left click menu item, it flashes briefly then text

reproduced this bug with a different menu after restarting computer. these kind of bugs make editor almost unusable on a mac. attached new video again:link text

Hey ,

Does this occur in every project? Does it happen after restarting editor? Does it occur with all Menus or only Toolbar icons?

Can you tell us your system specs and OS version? Any additional information you can give us might help us narrow down and reproduce problem. Thanks!

I narrowed it down a bit more. It does occur in every project, including after restarting editor, but only in these conditions:

  • using two monitors
  • click any dropdown menu (toolbars, menus, anything with a dropdown)
  • menus always work on one of two monitors but not other (perhaps not primary monitor?)

I discovered this when I had two windows open (one for materials, one main viewport), one on each monitor.

I also noticed a blank

striped panel shows up (screenshot attached). As for specs, I’m a bit under-specced right now, but all quality settings are turned way down: MBP early 2011, 16GB RAM, 512GB SSD, AMD Radeon HD 6490M, 2 GHz Intel Core i7, OS X 10.9.2

Hi ,

I keep running into related bugs and it all seems to come back to second monitor. Whichever Unreal window is open in second monitor will usually only accept input from a stylus, and not mouse/trackpad that remain working on other monitor. I am using a Yiynova monitor (similar to a Cintiq) but I doubt it is an issue with monitor drivers since I have never had this behavior in another application. I assume you guys are testing with Cintiqs, have you had any similar issues with those?

Hey -

For Blank Striped panel, this is Main Window background. You’ll see this if you’ve un undocked Main Editor tab from it. You can re-dock it as you would any other window, though you will not get docking guides.

For more pressing issue of drop-down menu’s disappearing on second display. This has been fixed for 4.1, but I have been able to reproduce this in 4.0.1 and have a workaround for you.

If you got to System Settings > Mission Control and uncheck “Displays have seperate Spaces” this issue will no longer occur. Keep in mind this change will require you to log out, and you will loose OSX Menu bar on your second display.

Bullard | Engine QA