Can't click button after changing level and creating new widget


So i’ve learnt that opening a new level deleted every variable stored in the BP player and the viewport. So I decided to create the widget I needed directly at the “event begin play” of the level I arrive in. After that, I set it to viewport and set his visibility to “Visible” (because it is set to hidden by default). All of this works, however, my widget contains buttons and I can not click on them at all and hovering them has no effect. I’ve trying setting up “set input mode game and ui” but nothing changed.
If someone could help me unterstand why.
I tried it without changing level and this works perfectly, I also made sure that I didn’t use variable coming from my BP player that were reseted by the level change.

Hope someone can help me :), thanks !

PS :

So the first screenshot is on my level BP, the last function leads to the function in the second screenshot (in my BP player), and the last screenshot is the content of the second function (in my game instance BP)


Solved by adding a delay node (of 3 secs for now) right after opening the level