Can't change UMG Text font size - why?

When i try to change font size under Appearance section, it changes - but after clicking Compile it goes back to original size. Same thing is happening when trying to change, for example, from Bold to Regular. Any clues?

Argh, solved it right after posting this question: “AutoKey” in animation timeline was turned on and it caused key adding from edited values :slight_smile: BTW. There should be a possibility to ‘exit’ animation editing mode, it might cause some confusion right now.
Happy New Year!

I don’t know if UMG looks the same as it was in Jan 01 2015, but apparently there was an ‘AutoKey’ button or checkbox somewhere near UMG timeline. There was a timeline for editing UMG widget animations at the bottom of the UMG editor. Turning it off and deleting all previously created keys solved that.

Hmm, so it looks like it’s a different thing, probably some new bug. Maybe create a new bug report for it.

I’m having the same issue but your solution makes absolutely no sense to me. Animation timeline in a widget blueprint? Or were you using your font in a different scenario cause I’m having this problem inside my widget.

Interesting… I didn’t even notice the timeline until you mentioned it :stuck_out_tongue:
It says No Animation Selected and it’s not creating any keys… Very strange.
Here’s a video showing what’s happening to me: UE4 Font Size Not Working - YouTube

I just figured it out. For some reason the font was getting smaller the more lines of text there were so I just typed in “I wonder” and it showed at a large font size. This got me thinking and it turns out it was due to the fact that I had the text block inside of a Scale Box which was throwing everything out of wack. I removed the Scale Box and just anchored the text block to full screen and the problem is solved. Thanks for trying to help though Slavq. Between the two of us maybe we’ll help some other people avoid the same issue in the future :slight_smile: