Download

Cant change UI image with hover (set brush from texture)? [Solved]

I am trying to switch a background image in an inventory UI.
I have no clue what is wrong with this blueprint (see image)
The standard background colour of the image is white (in the widget graph editor).
If anyone can tell if they can see what I did wrong, thanks in advance.

Looks good to me, I’m doing something similar and it works. I would narrow down the problem by:
(1) Make sure it works in the editor (and the 75/75 size matches)
(2) Call you’re SetHoevered function on BeginPlay or even better - on an input key pressed event. That is, make sure the function works regardless of the hover event.
(3) If all above fails, use PrintString node in the hover event to make sure the hover event is firing. You could also use a breakpoint, but print string is more clear to me.

Thanks for the reply Matan.
I know the Hover function is working, I tried it with the PrintString node.
When I changed the width and height, I could see change in the size of the image I was hovering, but it did not show the Hovered image, nor did it change back to the Unhovered image.

What about (1)? Not only the size. Remove the event, and just change the properties in the editor so it will show the texture, then play the game. Do you see it?
If not, it’s probably one of the properties.
If yes, try restoring everything, and calling you’re SetHovered function in BeginPlay or something, without any events. What do you see now? …

Everything worked, I just couldnt see the images change.
I think the problem was in the opacity of the UI panel.
After a bit of playing with the alpha settings and the colours the hover and unhover images managed to show up.
Thanks for the help matan!

Sure thing, glad you got it working :slight_smile:

p.s.
Would you mind adding a [Solved] text to your subject? would be nice to anyone else who has a problem like that / want to find other posts to help people :slight_smile: