Download

Can't change UE4Editor to run on Hign-performace Nvidia processor as default

Using Nvidia Control Panel doesn’t help the situation. And why UE4Editor does not run with NVIDIA GPU as default like so many other gaming applications?

this thread should help. In my case it automatically chose the NVidia GPU without any configurations in the control panel, so I never had any problems with this.
If nothing really works in the control panel settings the only thing you can do is set the “r.GraphicsAdapter” console variable in the config to use the NVidia GPU.