Can't change title bar icon Windows 4.9.1

Hi,

i cannot change the icon of the Window title bar (visible in window mode and on the taskbar), if i package the project using the editor.

I am using 4.9.1, i changed the icon of the exe and that works but the window title and taskbar icon is still the unchanged Unreal logo.

Thank you for your help.

Hi GreenWolf,

What steps are you taking to reproduce this on your end? Does this occur in a clean, blank project with no additional content or is it limited to one project?

Hi,
i changed in the project settings the icon of the project and then packaged a 64bit shipping release of my project, the icon i use is a 512x512 sized icon file.

I can see the changed icon on my exe.
I also changed the editor splash and the game splash (btw. if you change the editor splash, you cannot overrwrite the custom splash, you need to delete first your custom file).

If i now launch the game by using the exe, the windows title bar shows the unreal icon (But the correct project title), in the taskbar it is also showing the unreal icon.

This is reproduceable in every project.

Thank you for your help :slight_smile:

Do any other files work with the icon or is it limited to one file? Do you have a sample file that shows this error consistently? I’ll be happy to take a look and see what may be occurring.

It is very simple to reproduce, create a blank project, take a custom windows icon picture and change in the windows package settings (in the UE 4.9.1 Editor under project settings) the icon to your custom icon.
Package over the editor a 64 shipping build.

After that, the icon of the exe is now your custom icon (correct), but if you run the exe, you see that the task bar icon and the icon of the windows title bar of your running standalone is still the Unreal icon.

Hi GreenWolf,

I was able to reproduce this and have entered a bug report, UE-21446, to be assessed by the development staff.

@Adam: Is there any update on this ? Because I am also facing the same issue that GreenWolf mentioned.

Hi L34D3R,

Unfortunately, this bug is still under assessment. I do not have a timeframe of when a fix will be implemented.

Hi,

Is there any suggested workaround for this issue in the meantime? For example. I could add a post-build step to my build process which uses a command line resource editor to update the icon. The icon is being pulled from the GameName-Win64-DebugGame.exe executable found under \WindowsNoEditor\GameName\Binaries\Win64\GameName-Win64-DebugGame.exe

It appears the executable with the correct icon is just a stub at the root level which launches this other executable when ran.

Hi braindigitalis,

It looks like the bug may be fixed internally. If so keep an eye out for a future release with this implemented. For now I do not have a reasonable workaround for this particular error.

Stumbled onto this thread looking for a solution to this exact problem. My .exe icon is showing correctly, but my titlebar and taskbar icons are still showing the UE icon. I packaged a development windows 32 bit build.
And this is on 4.11.0.

According to the other post about this issue “UE-21446 was verified fixed in changelist 2801406” and “this issue has been corrected for 4.11”.

However I am seeing the same results as Mbublitz. My .exe icon is showing correctly, but my titlebar and taskbar icons are still showing the UE icon. I packaged a shipping windows 64 bit build using 4.11.1.

It seems like this is not fixed.

HI GeorgeDavis,

We have another discussion occurring on a thread started by Mbublitz, please continue the conversation here: