Can't build UE4.14 in Xcode 8

This might be a very basic fix, but I recently updated to OSX 10.12 and Xcode 8, and I cannot get ShaderCompilerWorker to build properly. Some targets such as UnrealLightmass or UE4EditorServices compile, but for the most part I get the following:

This is after running the setup and GenerateProjectFiles scripts.
I’ve tried validating project settings, though it’s puzzling that I didn’t have this issue before updating Xcode. Indexing also takes an inordinate amount of time after the update.

Any help is appreciated. Thanks!

Hello ,

Could you try upgrading your XCode version to 8.2.1? I don’t have a mac available with just XCode 8 installed but it’s compiling fine on 8.2.1. I’ll continue looking into this in the meantime but it would be best to try this first.

Hey Matthew! I’ve updated and still have the exact same issue, both with the script invocation and with indexing. I’ve tried running UE4.15 to see if I could reproduce the issue, but it runs just fine. However, I would like to get 4.14 working if possible.

I apologize, I missed this response. I noticed from looking at the log in your original post that you seem to be attempting to build ShaderCompileWorker for Development instead of Development Editor. Could you try changing that to Development Editor to see if that may help? You can do so by clicking on the UE4 scheme at the top left and selecting “Edit Scheme”.

I’ve gone into build configurations, however the only options available to ShaderCompileWorker are ‘Debug’ and ‘Development’. I went into UE4’s build settings but I can’t find a way to enable the other configurations. Would you know what I need to do here?

This is after changing UE4’s build configuration to Development Editor. I just can’t do the same for ShaderCompileWorker, and attempting to build either still fails.

Ah, I just noticed that that’s the same case for me, difference from Visual Studio. Can you check to see if there is a hlslcc folder in your Engine/Source/ThirdParty folder? Inside of it, is there a HLSLCC.Build.cs file?

Yup, I just checked and HLSLCC.Build.cs is there

Are you on XCode 8 exactly or on something like 8.2.1? It’s possible that the version of XCode you’re on wasn’t supposed in 4.14, especially since you didn’t see this happening until you updated.

Hey Matt, as per your direction in your first comment, I updated from Xcode 8 to 8.2.1. I had the exact same problem in both versions, which leads me to believe that it doesn’t have to do with the version, especially since you had a working copy. I’m not proficient enough to know what the error might be, so any clues would be appreciated!

Since I’m not able to reproduce the issue, I’m not sure of what else to suggest. Since you are able to compile 4.15, I would suggest to continue using that build in the future.

Hi there,
I am facing the same problem. Did you figure it out?