Can't build server using linux toolchain. File not found

Hi.
I have an engine copy that I built myself from github.
I wanted to try and build the server for my game, for linux, so I followed this set of instructions:

I downloaded clang 3.7.0-based because I have unreal engine v 4.13.2, I then set up an environment variable LINUX_ROOT to the directory of the toolchain, and then regenerated visual studio files, after which, a linux solution platform appeared in my project in Visual Studio.
I selected it, along with Development solution configuration, and tried to build it and it keeps failing with a bunch of errors saying that I’m missing a ‘new’ file. Here’s some of the output:

2>Runtime/Core/Public/HAL/PlatformCrt.h(5,10):
fatal error : ‘new’ file not found 2>
#include 2> ^

I tried rebuilding the engine itself with this configuration. No luck.

Any ideas as to why this could be happening?

Windows 10 pro, UE 4.13.2 (compiled from github), clang 3.7.0-based
Tried on multiple projects, and on the engine itself.

It appears that the new header file from the C++ Standard Library could not be found. This is very likely to be the result of an issue with missing / invalid references to ‘includes’ directories (which contain such vital standard / system header files), hence the compiler is unable to locate the files that have been #included by the C++ source code.

Hmm, after reading the linked article, it seems that all that’s necessary is setting a LINUX_ROOT environment variable to point to the right place and re-generating the project files, which you have indeed done. But have you restarted your system after setting the new environment variable? This step is necessary for the change to take effect properly (otherwise some programs will be able to see it and some won’t), but I’m not sure why that (arguably important) step wasn’t mentioned in that article given its potential to send unwary people on a pointless wild goose chase (when all they really needed to do was restart their system). So yeah, try restarting Windows so the change sticks, and try again. Good luck.

Hi.
I just tried restarting my computer, and I’m still getting the same error.

Hey Lord Northern-

The Compiling For Linux page is mainly to allow the game to be packaged for Linux. If you are trying to package a dedicated server, please try following the steps outlined here: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Cheers

Doug Wison