Download

Can't build for iOS and other bugs with Apple silicon/Failed to launch IBCocoaTouchImageCatalogTool

Hi,
has anyone here managed to build an iOS project on a Mac with a new Apple silicon?
We have a Mac Mini Developer Transition Kit equipped with the M1 processor, running mac OS Big Sur 11.0.1 RC and Xcode 12.2 RC.

With the previous versions of the OS and Xcode it was a huge mess even to compile the simplest thing, but as we are approaching the final releases the situation got better.

Despite this, we still have some major problems

  • the Unreal Editor crashes when you try to open the Project Settings. It seems to have something to do with the Metal render pipeline. (with all Xcode 12 beta versions)

  • the Unreal Editor hangs as soon as you open it, at “Finished discovering assets” (since Xcode 12.2, even with RC)

  • building an iOS project, either from Project Launcher or from command line with UAT, fails near the end of the Build command, when building the Asset catalog, with


Failed to launch IBCocoaTouchImageCatalogTool via CoreSimulator spawn

Underlying Errors:

Description: Failed to handshake with platform tool

Failure Reason: Failed to open connection over FIFOs with platform tool

Underlying Errors:

Description:

Recovery Suggestion: Try restarting your computer

Underlying Errors:

Description: Failed to open FIFOs for handshaking with platform tool

Failure Reason: IBCocoaTouchImageCatalogTool exited before we could handshake

While we can still live without the editor (help is appreciated anyway if someone has found a solution!), the last problem is a hard stop.

Needless to say that the common solution “Clean the project and restart Xcode” doesn’t work.
I’ve tried various updates and clean install of Xcode, cleaning the Xcode project, removing the Binaries/Intermediate folders and .xcworkspace, deleting Xcode caches and derived data all around the system. The problem still persists.

This seems however a recurrent problem that accompanied Xcode over the years, so somebody may have already encountered it in the past.

Thank you for your help.

Damn I was worried that there were going to be issues with the new apple silicon macs and it looks like my worries were justified, have you tried a 4.26 source build? maybe this issue has been fixed recently?

Do you have a regular x86 mac to test as well? Just to isolate the problem to make sure it is something to do with the new apple silicon?

Really sucks that command line UAT is is broken for iOS :frowning:

It’s not unexpected that nothing works on the new models, what with a complete silicon change. Support in 4.26 would be real good but I’m expecting 4.27 or an experimental branch.

[USER=“9”]Stephen Ellis[/USER] is there an ETA for updates to UE to support the new Macs?

I will add a little more context.

The project is building fine on three different Intel macs that we use for production for all Apple platforms (MacOS, iOS, TVOS). They run various versions of MacOS 10.15 and Xcode 11 or 12.
I’m pretty sure then that the problem lies in the combination M1 + Big Sur + Xcode 12.
I’ve also tried with a new empty project, getting the same result (fails at Asset Catalog generation for both iOS and TVOS target platforms).

If I create an empty iOS app in Xcode instead and add some image assets to it, it builds successfully.

By the way, I’ve managed last month to build our game for Mac target on the new silicon, the application runs on both new and old hardware without any problems.
And all the little fixes I had to do on the engine have been already replicated by Epic, so I guess I should just stop trying anticipating and wait for full support to come :smiley:

I haven’t yet tried 4.26, still going with 4.25.4, but I see a few new commits regarding the toolchain and build process for iOS have come up indeed.
4.26 seems to be in the staging phase, so I’ll try it as soon as it’s released in the next days.
I’ll also perform a clean install of Big Sur first and report back (the final release is out now).

I’m looking forward to Mr. Ellis’ answer too :slight_smile:

Thanks for support, have a nice weekend

So you managed a Mac build @Paibotm ? That sounds promising. I would be interested in the general experience of using UE4 with the M1 especially metal performance as I am thinking to upgrade.

does it work on a Intel base BigSur Machine?

I’m not a developer or Mac-savvy in the slightest, but I understand 4.26 will have some early/alpha support for compiling non-editor macOS targets to run native on Apple Silicon.

No word yet regarding running the Editor. Stay tuned.

this does not sound good, I hope we get editor support in q1 at least. This is definitely going to push some people toward unity, no doubt about it.

I read that the Unity editor compiled for native Apple silicon won’t be here until at least 2nd half of next year so I’d imagine Unreal will have the same if not larger task in their hands. Its just a lot of work, excited if it happens (hopefully) :slight_smile:

Well epic could at least test it to make sure that it works fine under rosetta as a stop gap until they have a full native implementation, this is what unity is doing. Currently there are conflicting reports on discord that the unreal engine editor works at all on arm based macs and the OP said that UAT doesn’t work at all.

Anyone know if you can build the UE4 editor on an Apple Silicon Mac for Intel and have it run in Rosetta? I’m in a position where I may have to get a new Mac pretty soon and would rather get something with an M1.

It is not officially supported there have been conflicting reports that it works, I will also be getting an m1 mac soon so I’ll test it out thoroughly and report back here once I do

[USER=“9”]Stephen Ellis[/USER]

Sorry for the ping. Do you happen to have any information regarding running the editor on M1? I am seriously thinking about selling my PC and switching to an M1 Mac. I am familiar with the OS and I like it better than Windows. Every single app that I use for photo/audio/video editing, texturing, modelling etc works perfectly on M1 - most of them from Day 1.

However I am an entrepreneur working with Unreal Engine, and this is my only source of income. So until Unreal Editor runs on M1 without crashing or glitching, I will not be able to make the change, even though I could keep a nice sum of money from selling my PC while still buying an M1 Mac. Not to mention the huge reduction in my electricity bills if I do swap to M1.

If you could share some information if there are any news, I’d really appreciate it.

Thank you!

I don’t know if this issue has been resolved (I’m still running a 2017 Quad-core Intel iMac and haven’t made the switch to M1 yet) but from what I’ve found, basically all Macs need to run UE4 4.19.2. Anything newer than that “locks up” the system. That being said, my iMac turns into a Harrier jet anytime I run UE4.