Can't build engine in "Debug" configuration

Hello,
I’m trying to debug my game itself as the attached debug target (I want to be debugging immediately when the native Windows code begins running the process, and if I am debugging the Editor and playing in a new window, I can only attach after it’s started and running). So I have created a GitHub fork and tried building the engine in “Debug” (Engine + Game in Debug), and I get the following build error:

1> …\Build\BatchFiles\Build.bat UnrealLaunchDaemon Win64 Debug -waitmutex
1>EXEC : error : UnrealLaunchDaemon does not support the Win64 platform.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command “…\Build\BatchFiles\Build.bat UnrealLaunchDaemon Win64 Debug -waitmutex” exited with code -1.
1>Done executing task “Exec” – FAILED.
1>Done building target “Build” in project “UnrealLaunchDaemon.vcxproj” – FAILED.
1>
1>Build FAILED.

I took the link below’s advice and re-ran the Setup.bat, but still got the same result. Is this a packaging bug?

Thanks!

When I try to run the UE4 solution, I get this error:

Hey Embeddetech-

When compiling a source build of the engine it has to be built in DevelopmentEditor before building in any other configuration will work. After building the engine with Development editor you should be able to build in Debug.

Cheers

Doug Wilson

Hello again Doug! :slight_smile:
Below is a snapshot of a successful DevelopmentEditor build followed by a failed Debug build. Have I goofed something up in my setup? It looks like the projects that failed are UnrealCodeAnalyzer.vcxproj, DsymExporter.vcxproj, UnrealLaunchDaemon.vcxproj, and UnrealAtoS.vcxproj.

Which branch/version of the engine are you trying to build? I tested building the 4.9 version on my machine in Debug (had already ran in DevelopmentEditor) and it completed successfully.

I couldn’t remember, but I’m pretty sure it’s off of the release branch:

I currently have four projects that are failing build, but I can run the project in the “Debug” configuration, however I get this “Failed to open descriptor file” error:

[descriptor file error…]:

Hi Doug,
I deleted my previous working files and re-cloned the 4.9 branch. Here’s exactly what I’m trying to do.

I’m needing the game window to not be displayed by default when the game starts, so that the game is initializing and running but the window itself isn’t displayed until all the way in the Level Blueprint BeginPlay, where I can do some configuration of the view and wait until the view is stable before displaying it.

I also really need this to be in the deployed build, as we will have users that will be doing their own development, and this part of it, in the engine, I really don’t want to have to make them rebuild the engine. So I’m planning on doing a pull request when I get this working.

So here’s exactly what I’m trying to do. First, I want to add a boolean in the BaseEngine.ini file that indicates whether the game window should be shown on startup by default. I have added this in Engine.h, under the bAllowMatureLanguage bit, line 1272::

/** whether mature language is allowed **/
UPROPERTY(config)
uint32 bAllowMatureLanguage:1;

/** whether to show the game window at startup, or let the game do some window configuration before showing **/
UPROPERTY(config)
uint32 bShowGameWindowOnStartupByDefault:1;

Then in BaseEngine.ini, I add the default configuration for this boolean to be true, underneath the bAlllowMatureLanguage setting, at line 43:

bAllowMatureLanguage=false
bShowGameWindowOnStartupByDefault=true

Then, in GameEngine.cpp, at line 321, I replace the code to show the window:

Window->ShowWindow();

with code that first checks the setting, and only shows the window if the default setting is true, so that it doesn’t affect most users:

if (GEngine->bShowGameWindowOnStartupByDefault)
{
	Window->ShowWindow();
}

Comment to be continued due to character limitation…

[Continuing comment…]

If I can just get this to work, and run to the level blueprint’s BeginPlay event without showing the window, and I can write a C++ class to do some stuff and show the window, then weeks of agony and lost productivity for the team will be over. Any help you can provide would be greatly appreciated.

When I compile this in Development Editor configuration, it compiles fine. When I run it, and create a 3rd Person C++ project, and then run the editor, and then run the game in the local viewport, it runs fine, because the code I added isn’t being executed. However when I run it as a standalone game to see if it will not show the game window, it shows the exception shown below.

Am I following the correct procedure for adding an engine setting? Is there anything you know if that would cause this to not work?

Thanks!!!

Hi Embeddetech,

I was looking over this post, and was a little confused. I just wanted to check and make sure I understand what you are trying to do. From your first post and one of your other comments, it sounds as though you want to be able to launch directly into your game using Visual Studio’s debugger. Is that correct?

Tim

Hi Embeddetech,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but please feel free to add a comment and re-open the post at any time if you need any additional assistance.

Tim

Hi Tim,
Thanks, I actually just worked through this issue a couple days ago after working a 36-hour all-nighter. I didn’t resolve this particular issue but was able to solve the core issue using a different route.

Thanks for all your help!