Can't build 4.7 from source, compile failed

I try to build the latest 4.7 branch from source, but unfortunately the compiling fails. Before today it always worked.

I tried it now 3 times and it always failed with the same Error, I even disabled my antivirus program.

1>ERROR : UBT error : Failed to produce item: E:\Downloads\UnrealEngine-4.7\UnrealEngine-4.7\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Landscape.lib
1>  Cumulative action seconds (6 processors): 0,00 building projects, 13394,72 compiling, 0,00 creating app bundles, 0,00 generating debug info, 110,54 linking, 0,00 other
1>  UBT execution time: 2425,79 seconds
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command "..\..\Build\BatchFiles\Build.bat UE4Editor Win64 Development" exited with code -1.
========== Build: 0 succeeded, 1 failed, 1 up-to-date, 0 skipped ==========

Does the file E:\Downloads\UnrealEngine-4.7\UnrealEngine-4.7\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor-Landscape.lib exist on your local filesystem?

No, it does not. But I have one file called “UE4Editor-Landscape.lib.response”.

Is there anything else in the log?

Of course, the log is quiet long but the rest is not of importance I guess.


This should be very easily be reproducible, just download the most recent 4.7 branch and try to build it, or could the error only happen to me?

Ahh yeah, this is the issue:

1>E:\Downloads\UnrealEngine-4.7\UnrealEngine-4.7\Engine\Source\Runtime\Landscape\Private\LandscapeCollision.cpp(349): error C2065: ‘MeshGuid’ : undeclared identifier

Looks like 4.7 is broken (red) - this will be fixed presently but if you want to move on just replace MeshGuid with HeightfieldGuid (effectively reverting the most recent change to that file).

Since this needs an answer to be marked as resolved, here is the answer. Issue was fixed in updated 4.7 branch.

Thanks, was fixed really really fast :slight_smile: So let’s see whether I can use my project now or I will have to write a new answerhub bug post in 10 minutes :stuck_out_tongue: