Can't build 4.24 from source code in macOS Monterey

Has anyone been able to start the process of building any version from source code in macos Monterey? I tried to build 4.24 from the source code at

While you can right click to open the setup.command file because it’s not signed, that opens terminal and tried to run a lot of other programs inside, and when that happens, your choices are only cancel or move to trash. If you cancel, it will prompt you for the same file over and over.

In the General tab of the security and privacy settings, the “allow apps etc” is set to App Store and identified developers. And after trying setup.command and getting those prompts, the program that caused it appears there so you can allow it, but the process of building from source code surely needs a lot of different CLI programs running, and if you have to stop the process and then allow it, it would never end, not to mention that your only choice is “Move to the trash”, so you would have to unzip the downloaded file over and over.

Does anyone know how to make this work?