Can't build 4.14.3 from source: Xcode 8.2.1

Hi,

I’m trying to build UE4 from source using Xcode, and am following the GitHub readme steps. I have downloaded as a .zip, run the two .command files and opened the Xcode workspace file. I selected the ShaderCompileWorker and built that, which worked fine. However, when I try to build UE4 itself, it simply hangs at about 10% progress. I’ve left it for over 2 hours, and nothing.

This has happened multiple times. I’ve tried starting again with a fresh download of the source code. I’ve tried opening the branch in GitHub desktop rather than download a .zip. I’ve tried building 4.13 instead. Nothing seems to work, and it always hangs at this point. It must be something wrong on my end since I’ve seen reports of others successfully building with this method and this version, but I’ve tried on multiple Macs (one running El Cap, one running Sierra) and the same thing happens.

Does anyone know what the issue might be? Or where I should start looking? I’m not familiar with Xcode at all really.

Hi BRITHamish,

If you have not already, I suggest removing all UE4 files and starting over following the steps outlined on the following documentation pages (be sure you are on the Mac version by selecting the appropriate button at the top of the page):

Downloading Unreal as a Zip from GitHub

Building Unreal Engine from Source

If unable to install the engine following these steps, please make a note of any steps that were not clear or that you received an error on.

Be advised to run UE4.14 and greater, your OS will at least be Sierra.

Steve H.

I don’t know if this helps, but if you download the Unreal Engine launcher, create your C++ project from there, there is now an option to include unreal engine source code… Just a thought, it might get around that issue by avoiding any confusion in the git process :slight_smile:

Hi Steve,

Thanks for the reply. Unfortunately I’ve tried removing all files and starting from scratch, and have even tried it with different versions of UE4 just to check, and still no luck. I’m building on Sierra 10.12.3, and tried on 10.12.2 as well.

It just seems to hang at the building stage for UE4 itself no matter what I do. I’ve allowed files to finish indexing as suggested elsewhere, and the ShaderCompileWorker builds without problem so I’m very confused.

Those are the guides I’ve been following, and it’s right when I try to build UE4 itself that I run in to issues. Oddly I don’t even receive an error, it just hangs on building and never goes anywhere even if left for hours.

Please try the following…

  1. Make sure your Firewall or any other antivirus settings are not blocking UE4 from installing components

  2. Delete the DerivedDataCache folder from the install directory and try to building UE4 again. If it fails, proceed with the following:

  3. After building the ShaderCompilerWorker for Development>Mac, build the next three in this order:

  4. UnrealLightmass for Development > Mac

  5. CrashReporterClient for Shipping

  6. UE4 for Development Editor (if it hangs here again, delete the DerivedDataCache folder from the install directory and try this step again)

*Make sure each finishes before proceeding to the next. Let me know if this does not resolve the issue.