Can't block directional light in Lumen ?

Hello everyone,

I’ve started a small scene for my portfolio and to see what’s up with ue5, when trying to get my first phase of lighting done during the block out i’ve used invisible wall to block the sun where i do not want it (since it’s a diorama).
For the mesh parameter i’ve unchecked “Render in Main Pass” and checked “Hidden Shadows” and “Actor Hidden in Game”.

When I have it visible on my scene it does the job

but when I hide it with “G” and move around/zoom out or hit play in level you can see it clearly doesn’t block anymore the sun

If anybody has any idea that would be cool thank’s !

When you place a basic shape like a cube in your level and disable just the RenderInMainPass do you see the same behaviour?