Can't attach to hand socket in VR


  1. Create VR template project (Blueprint)
  2. Add a socket to MannequinHand_Right(Skeletal Mesh) with a relative position different from (0,0,0)
  3. Modify a pickupable object’s Blueprint so it would attach to a socket:

  1. Start the game and try to grab object: It will snap into the middle of the hand.

This is how I modified the Skeletal Mesh:

But this is what I get:

I changed the blueprint a bit, now it works just fine, but it doesn’t want to detach when I release the trigger. (It worked before the change)

Any idea what should be changed also?

Tried that one too. It needs a Target, can’t be left as “self”. Tried to wire in the “K2 Get Root Component” and the “Static Mesh Component” too, but neither of them worked for a reason. Any further guess?

Can you confirm the Event Drop is triggered properly by the Interface, just the DetachFromActor node doesn’t seem to do its job?

Ok, found the root cause. It is actually in the way the BP Motion Controller handles the release. Before invoking the Interface Drop function, it checks that the object attached to the hand is still there. Since you are attaching it to the HandMesh and not to the Motion Controller component, the check fails every time and the Drop event is never called. See below.

If you modify the Release Actor function as follows. it will work both with the original Pickup Cubes and with you modified socket attachment.

Did you try with DetachFromComponent instead of DetachFromActor?

Thanks for your efforts! Yes, this was the cause. I wonder if it would have been easier to start with an empty project, and write these myself, but this’s my first VR project, so I didn’t dare to.

Hey, sorry to bump but your post and answer was exactly what I was looking for although it doesn’t work with the left hand. Any solutions for that?