Can't assign level as default map in project settings

This happens when the name of the folder where the level is contained on contains ‘[’. Instead of the level being assigned in the project settings’s default map, it just ends up with “None”. Remove the ‘[’ from the name of the folder and it works as intended.,

these settings are written to a .ini file - and in a ini [] have special meaning! simply don’t use them :slight_smile:

Hello water2112,

Adnoh is correct and this is due to .ini files using [ and ] for syntax purposes. This causes the filepath to appear incomplete in the .ini file where this setting is stored. While this is expected, I’ve entered a bug as we should be handling this in some way. You can find the report here: UE-42046

I believe the fix will be to stop users from entering these characters into folder names but there could also be some sort of fix to allow the editor to handle these correctly. It’ll be up for the developers to decide.

Have a nice day!

Now I know why, but I do agree that there should be some sort of warning or some workaround by the engine to handle these kind of instances. I think it would be easy to add a warning since you already have warnings for using characters such as ‘/’, ‘!’, ‘?’, ‘.’. This would be nice to prevent confusion.

UE should’ve warned me then not to use those characters for a folder, file name. Thanks for the info btw. :slight_smile: