Can't Add/Edit Environment Query node


Since 4.9.1 everytime i try to create a new EQS node or edit an existing one engine crash.
No specific message and “no minidump found for this crash”.
Same in blank project.

Was working in 4.9

My specs : i7 920, 8go Ddr3, r9 280x


Hi kumoshiroi,

Please find log from your project’s \Saved\Logs folder and attach it here. Thanks!


I’m running Windows 10 64 by way.


link text

Thanks. I can’t reproduce this in a 4.9.1 project here (Windows 7), so I’m going to try to get ahold of a Win10 machine sometime tomorrow to test.

Any news? I completely reinstalled 4.9.1 and still same problem.
Really annoying cause i was working in a.i., isn’t there a way to reinstall 4.9.0? or some preview 4.9.2 with bug fixed?
Thanks again for your help.

We can’t reproduce on Win10, so I don’t think that’s issue.

My first guess is to re-check your Editor Preferences > Experimental and make sure Environment Querying System is still enabled in 4.9.1. It’s possible that was turned off in update, or config file wasn’t updated correctly.

If you need to roll back to 4.9.0, you can get it from GitHub and build it from source. I’m not 100% sure that a project used in 4.9.1 will open in 4.9.0, however, so I’d like to help resolve this issue in 4.9.1 if possible.

As i said, it’s same in a blank project so i did have to tick EQS in experimental feature.

I’m building 4.9.0 from GitHub i’ll let you know if it works.

If you have any idea of what could have cause this problem please let me know cause i litterally didn’t change anything other than upgrading to 4.9.1 and my windows install is a fresh as it gets (no upgrade from 7 or 8, clean install)


Update : Working in 4.9.0, so definitely a bug related to 4.9.1 in my opinion.

Hm. It’s possible something got corrupted in upgrade to 4.9.1 in actual engine .ini settings. If you don’t mind, can you reopen 4.9.1, disable EQS in Editor Preferences, and click Set as Default. Close editor, then reopen. Create a new project, re-enable EQS, and try again.

Let me know if that doesn’t work. I’ll take a look at engine .ini files and see which handles this setting, and see if wiping it will resolve issue.

I did as you ask and unfortunatly it didnt work.
But at least in meantime i can use 4.9.0

Hi kumoshiroi,

Are you running DX12? Please get your dxdiag and attach it here. Thanks!

Hi kumoshiroi,

We haven’t heard back from you in a while. Are you still experiencing this issue? Are you running Win10 with DX12? I’m going to resolve this post for tracking purposes for now, but let me know if you’re still experiencing this issue and whether you’re running DX12, and I can continue investigating. Thanks!

Hi, as it says in log, i’m using DX11.
I updated my rig to new motherboard and i5 6600K, using 4.9.2 and everything works so far.

Thanks for letting us know. I’ll mark this as resolved for now, but please let us know if problem occurs again. Thanks!