Cannot use enums as Map keys in some cases

TextSpeed is my enum. In blueprints I made a Map of . I can get values from Map by using enum from combobox inside Find node.

If I connect Variable, which is TextSpeed type to Key input of Findnode, I get an error.

I found workaround by cast TextSpeed value to Byte. My guess is that those values really are byte types, but blueprints shows them as TextSpeed.

Hi dzarafata,

Thank you for the report. I was able to reproduce this behavior, so I’ve created JIRA UE-42747. Our developers will be investigating further. Follow that link to monitor the status of the report.



Hi. I have worse problem realted to first one now. I did not touch my project since my report. No i wanted to add something to it and it crashed while compiling blueprint. I ran debug in Visual studio and found out crash is related to Map named textSpeedsMap while calling rehash method. The Map from report was only Map of TextSpeeds used in my project so it have to be it.

It seems that Maps don’t work to well with enums in BP.

Callstack etc. is visible in the image. It happens every time I try to load my project.

Thanks for the additional info. I would suggest avoid using containers with enums for the time being while we get the kinks worked out.

See if you have a backup before implementing the map/enum so you can get back into your project.