Download

Cannot upload mod to steam workshop?

9acd7c44795ed755523cc7bc7369881d3ce323ad.png

Anyone have any ideas?

Do you have steam closed completely?

I did have yes

It is likely you have steamguard on your account and if so go to C:\Program Files (x86)\Steam\steamapps\common\ARKDevKit\ModTools\SteamCMD, run steamcmd.exe, enter “login <username> <password>” without quotes and replace the bracketed items with your login information. From there if you have steamguard enabled on your account (and I recommend everyone does) it will ask for the code. Then you can type “exit”, and attempt the upload once again.

If that is not the problem, I was also running in to problems with my mod uploader when I was attempting to delete a mod. To solve it I ended up deleting my entire modtools directory and then verified the dev kit, but all you should need to do is verify the dev kit.

I haven’t tried that yet and do have steamguard, I’ll give it a shot thanks :slight_smile:

Exact same problem on my end. It is not Steam Guard causing it since I already took care of that and yet it still happens. I wish there was a more reliable way of uploading content to the workshop…cause this is a bit redic.

Try doing what I mentioned in the second half of my response: deleting the modtools directory and verifying again (you may need to re apply the steamguard login after this).

Doing that now, will let you know the results. Mind you, this happened after a fresh reinstall of the Dev Kit even, but I hope this works

I had the same issue, I just remade the folder with everything back in it working properly and uploaded that. Worked great.

verified after deleting that folder and worked.

Thank you very much

I tke that back. Went to update a small glitch and now it shows as (limit exceeded) error.

and the mod ont he workshop is 0mb and has no title, picture or description.

Are you cooking the entire map? Or just a generic mod?

just a generic mod, only these files + the generic map and gamedata BP:

http://puu.sh/iUo3k/6325f83523.jpg

Got it - the picture for the mod was too large.

Worked now!

Just got that error too, gonna try it without the picture.

UPDATE: That was it, son of a …lol. Wish I would of known that a long time ago. Maybe my full mod will be able to upload now and really wasn’t past the max file size limit?

Nice to know that there is also a limit on the preview image (however you can add videos and images after the fact) but I think Drake mentioned somewhere there is a file limit they are trying to get steam workshop to increase for mods.

Hello, I’m trying to upload my mod of a structure to workshop but I’m not able to, I tried to follow the only tutorial I found but the mod does not work and when I install it on my server the server suffers a fatal error when starting. Could someone tell me where there is information about it? Or explain how to upload a mod without dying in the attempt? greetings and thanks. :frowning:

AFAIK the Image size is 800x800 pixels or at most 1000x1000 pixels for the icons for steam to upload properly