Cannot Teleport Custom Pawn

I am trying to teleport my pawn and it’s not working. The Blueprint is in the pawn bp itself and the rest of the script runs fine, but it will not teleport. I have tried Teleport, SetActorLocation, and SetActorLocationAndRotation. I have also tried setting the target to self.

  1. Is the “golfball” actually the player pawn that is being controlled in your game?
  2. You know your current teleport location is set to 0,0,0?
  3. I don’t understand your “switch on int” the one off the “true” branch goes to nothing, the one off the false doesn’t need to “switch” at all since there is only 1 input. And if that input isn’t “1” it won’t execute.

So there are many things that could be wrong with this blueprint.

Here is a tutorial I made going over “teleportation” maybe it can help you figure out what your issue is.

  1. Yes, the golf ball is being played.

  2. Yes, it doesnt teleport no matter the coordinates.

  3. The switch on the top I haven’t done yet as it also requires teleportation and the switch on the bottom will lead to more, I just haven’t done it yet for the same reason as the top.
    All the code works fine, I have tested each section with a print screen after each node, it just doesn’t teleport.

Hmm, maybe a setting like “simulate physics” or something, sometimes physics doesn’t like to play nice with other nodes.

Actually, it didn’t work. I have no idea why it worked that one time, but it doesn’t now.

Are you sure each component has physics turned off? Also maybe try “set actor location” instead of the “teleport” unless you specifically need to use that node.

Only the sphere has collision, which is now turned off. I have tried both Teleport and SetActorLocation, neither of them work.

Hmm, but you say it did work for one trial? Weird, can you post the full blueprint for this? How the entire thing is called and executed start to finish?

I think that one trial is because I accidentally crushed the ball through the floor. The whole process spans multiple blueprints and is very unoptimized. The node does get called, however it doesn’t teleport. Hopefully you’ll be able to see those. link text

Sorry, I don’t have 4.19 could you possibly upload more screen shots for me to look at?

Its fine. Im not gonna finish this as there are a million more problems with it.

Teleporting doesn’t seem like it should be that big of an issue, it is probably something small/simple you are missing but if you don’t want to try and fix it I guess I can’t stop you haha