Cannot start UE4 on (Arch)Linux; renderer issue/weak system?

SOLVED(?): After leaving the engine to run a few times, I’ve decided to throw “free -m” every 10 seconds to monitor memory usage. Shaders are finally compiling. I’ll investigate this further and update the wikis if I can reproduce this properly. I find it hard to believe I’m preventing this from being killed just by checking memory.

When starting by default as Vulkan, it hangs at 18%:


LogMaterial: Verifying Global Shaders for SF_Vulkan_SM5

Using -opengl4 hangs at a similar message, this time 25% loaded:


LogMaterial: Verifying Global Shaders for GLSL_430

The only error logging I can find is two line just before:



Shared data cache path not found in *engine.ini, will not use an Shared cache
Unable to find inner node Shared for hierarchical cache Hierarchy


Is this because my system requirements are too low? I have run UE4 in the past on Windows10 in the same machine, which only started getting sluggish at high+ quality settings.

Using UE4Editor-Linux-Debug
Ran Setup.sh, GenerateProjectFiles.sh
Recloned from git and reinstalled UE4 multiple times
Reinstalled vulkan-icd-loader and vulkan-intel

CPU: i5 8250U 1.6GHz with UHD graphics 620
RAM: 8gb

I have 7gb ram free when running UE4Editor. I am currently combing through the logs for anything at this point.

EDIT: Verified that UE4 is working under Windows10, with several Chrome tabs and a 50,000 vert model in Blender (Eevee render, no texture). My laptop being too weak for UE4 doesn’t seem to be the cause here.

I’m getting the same issue. Launching ./UE4Editor I get to 18% and then it hangs here:

  LogMaterial: Verifying Global Shaders for SF_Vulkan_SM5 

Hardware:

Core i5
GTX 1060 3GB
Ubuntu 16.04

Drivers, followed this guide and install nvidia 4.30:

Unreal Build Steps:

git cloned the repo (4.24.2)
Setup.sh
GenerateProjectFiles.sh
make
cd UnrealEngine/Engine/Binaries/Linux/.UE4Editor

**UPDATE [SOLVED]: **I let the process run this time (don’t kill it!) for about 15 minutes and got past this step. Then it went on to Log a whole bunch of stuff about “LogShaderCompilers: Display: Worker etc…” and take an additional 10 minutes before launching the editor!

My guess is Linux thinks it’s hanging or something and kills it, so running UE4Editor over and over will eventually compile all the shaders.

I’m trying to get Vulkan to work now. This problem is exclusive to UE4, and I’m using Intel 620 graphics. Gonna comb through the source when I can.
VulkanRHI::vkQueueSubmit() results -4, VK_ERROR_DEVICE_LOST. Something about memory.

OpenGL sucks for me, but it works.

Just wait for it.