Cannot package game using an old re-compiled plugin, help! Missing precompiled manifest

Hey. I am trying to package my game using the Project Launcher but the plugin I have used for my flying AI is giving me this error:

ERROR: Missing precompiled manifest for ‘DonAINavigation’. This module was most likely not flagged for being included in a precompiled build - set ‘PrecompileForTargets = PrecompileTargetsType.Any;’ in to override.

This plugin didn’t receive any updates for versions higher than 4.19 however I was able to find a re-compiled version for 4.27 and I got it to work successfully. However, I’m pretty new to Unreal and could not find a way to solve this new error I’m getting. Here is the re-compiled version:

I tried adding the line PrecompileForTargets = PrecompileTargetsType.Any; to the .cs file specified in the error but I believe I have to rebuild the plugin for it to take effect, because the error persists even if I add the line “PrecompileForTargets = PrecompileTargetsType.Any;”.

Could anyone help me out? I tried following some tips online but couldn’t solve this. Would really appreciate any help since I need this plugin in my game! Thanks a lot, have a great day/night. :sweat_smile:


OK. So no one had anything to say! :sweat: However, I figured it out after working on this simple issue for hours… If you are having a similar issue, maybe my solution will help you. Maybe it won’t.

What I did was simply create a “Plugins” folder inside my game project and move the re-compiled plugin from Engine\Plugins into the folder I created. That seemed to solve the error for me and I was able to compile. Hope it helps!

1 Like