Cannot package for HTML5

I’ve tried to package for HTML5 with two (Blueprint only) different unrelated projects, and here’s what I get:

MainFrameActions: Packaging (HTML5): UnrealBuildTool: Performing 1 actions (4 in parallel)
MainFrameActions: Packaging (HTML5): UnrealBuildTool: [1/1] python.exe MyProj.js
MainFrameActions: Packaging (HTML5): UnrealBuildTool: INFO:root:(Emscripten: Running sanity checks)
MainFrameActions: Packaging (HTML5): UnrealBuildTool: error: Linking globals named '_Z14UELinkerFixupsv': symbol multiply defined!
MainFrameActions: Packaging (HTML5): UnrealBuildTool: Traceback (most recent call last):
MainFrameActions: Packaging (HTML5): UnrealBuildTool:   File "C:\Program Files (x86)\Epic Games\4.12\Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.35.0\emcc", line 1309, in <module>
MainFrameActions: Packaging (HTML5): UnrealBuildTool:     final = shared.Building.llvm_opt(final, link_opts, DEFAULT_FINAL)
MainFrameActions: Packaging (HTML5): UnrealBuildTool:   File "C:\Program Files (x86)\Epic Games\4.12\Engine\Source\ThirdParty\HTML5\emsdk\emscripten\1.35.0\tools\", line 1465, in llvm_opt
MainFrameActions: Packaging (HTML5): UnrealBuildTool:     assert os.path.exists(target), 'Failed to run llvm optimizations: ' + output
MainFrameActions: Packaging (HTML5): UnrealBuildTool: AssertionError: Failed to run llvm optimizations: 
MainFrameActions: Packaging (HTML5): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Bla\MyProj\Binaries\HTML5\MyProj.js
MainFrameActions: Packaging (HTML5): UnrealBuildTool: Total build time: 38.01 seconds
MainFrameActions: Packaging (HTML5): CommandUtils.Run: Run: Took 38.1419162s to run UnrealBuildTool.exe, ExitCode=5

Tried on Windows 10, with Visual Studio 2015 installed (And working when compiling UE4 C++ projects). Let me know if you need more information.


Could you please provide me with screenshots of the HTML5 Project Settings from within the Editor? Are you using the Binary or Source version of the Engine?

Looking forward to hearing back from you, thanks!

Hi ,

Thank you for your reply. Here you go:


The HTML5 SDK one is totally empty (there is just a section called “Available browsers” with an empty list), hence I didn’t take any screenshots.

Let me know if you need anything else.


Could you add your browsers to the Available Browsers list? That is one thing we have different between my editor and yours. Here is an example:

Once you’ve done that, could you open up a blank project and try to package it for HTML5?


Hi again,

Tried adding a browser, and tried compiling an empty project with the same result (also, I don’t think Emscripten uses the browser for anything anyway…)


Adding the browsers will make them show up in the launch menu. This would let you see if it’s a launch and packaging issue or just a packaging issue.

I’m still looking into this for you, but here are a few suggestions:

  • Have you tried going into your Epic Games Launcher and verifying your version of the engine?
  • Have you checked in the ‘Options’ under the drop-down menu for your version of the engine and made sure HTML5 was included in your installation?
  • Are you on a full version of VS 2015?




Hey Arcnor,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

Hi ,

This is not resolved, I just forgot to reply to your last comment, I’m doing that now

All those things are correct, and I’m on a Community version of VS2015.

I’ll try that when I get the opportunity, but if you look at what I posted above, I’ve tried this with a blank project, as well as with other kind of projects.

can you do a full rebuild and post your build’s log file?

your OP shows this:

MainFrameActions: Packaging (HTML5): UnrealBuildTool: error: Linking globals named ‘_Z14UELinkerFixupsv’: symbol multiply defined!

this is a programming error – you might be able to clear it from a full rebuild – or else, one of your functions is already defined – a full log will help determine what’s going on…

It happens. Thanks for the update. :slight_smile:

Once you try what has suggested, could you post your results? While you’re at it, if you’re still running into trouble, could you also upload your error output logs from the blank template project?

Thank you!

a blank project usually builds pretty clean – can you also try the following suggestion from this post:

Thanks, I think that might actually be the issue. I’ve tried on a separate computer with no plugins installed, and I didn’t get that error (I actually got a different one :D, but I might not have some of the requirements installed).

We’ve decided not to pursue the HTML5 venue anymore for now, the process is far from “build and play”.

Thank you both!

You’re welcome, let us know if you run into any other complications.