Cannot package a plugin for Windows, because 'Android is not a valid platform to build'.

I have made a plugin that I want to package, but I am unable to. The output log states:

LogPluginBuilder: Building plugin for target platforms: Android, IOS, Linux, LinuxArm64, Win64

LogPluginBuilder: Running: C:\Program Files\Epic Games\UE_5.2\Engine\Binaries\ThirdParty\DotNet\6.0.302\windows\dotnet.exe “C:\Program Files\Epic Games\UE_5.2\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” UnrealGame Android Development -Project=C:\UE5\BTPlusPlugin\Build\BuiltPlugins\BehaviorTreePlus_5.2\HostProject\HostProject.uproject -plugin=C:\UE5\BTPlusPlugin\Build\BuiltPlugins\BehaviorTreePlus_5.2\HostProject\Plugins\BehaviorTreePlus\BehaviorTreePlus.uplugin -noubtmakefiles -manifest=C:\UE5\BTPlusPlugin\Build\BuiltPlugins\BehaviorTreePlus_5.2\HostProject\Saved\Manifest-Unrea

lGame-Android-Development.xml -nohotreload -architectures=arm64 -log=“C:\Users\ADMIN\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_5.2\UBT-UnrealGame-Android-Development.txt”

LogPluginBuilder: Log file: C:\Users\ADMIN\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_5.2\UBT-UnrealGame-Android-Development.txt

LogPluginBuilder: Platform Android is not a valid platform to build. Check that the SDK is installed properly.

LogPluginBuilder: Took 0,8936889s to run dotnet.exe, ExitCode=6

LogPluginBuilder: UnrealBuildTool failed. See log for more details. (C:\Users\ADMIN\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_5.2\UBT-UnrealGame-Android-Development.txt)

LogPluginBuilder: AutomationTool executed for 0h 1m 21s

LogPluginBuilder: AutomationTool exiting with ExitCode=6 (6)

LogPluginBuilder: ----------------------------------------------------------------------------------------------------

LogPluginBuilder: Error: [Return Code] 6

I have tried traditional packaging and Plugin Builder with Windows64 as the only selected option. Both result in the same message. In Project Settings, both locations of Android SDK are empty, since I never worked with Android in Unreal. Any idea how to get rid of that?


Hi Cyber.Dwarf,

Have you had a look through this document?

FIXED. Since I wanted to package it only for Windows, I simply added

“PlatformAllowList”: [

Inside “Modules” in my .uplugin. Now the plugin packages like a dream.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.