Download

Cannot Order Parameters error. Please help.

Hello,

I’m having one of those WTF moments and i can’t understand what’s happening or why it is happening.

I’m new to UE4 so it’s understandable but still, i tried everything i learned and nothing worked.

I get this error and can’t compile i traced the source of the problem and i saw that the interface that contains the function is the problem or rather the function itself with the “count” but i tried to delete the input and type again “ammo” but it wouldn’t let me, it changes automatically to the last thing that was typed in there.

It’s the first time that i see something like this, not being able to type the name of the input and having this issue…

Please any help would be highly appreciated!

Thank you very much in advance!

Ok, nevermind i fixed it.

I created a new function and named it differently, added the same input(ammo) and all the same. Called the new function message and linked it up the same way and that fixed the issue…

This was a clear bug from UE4. The function was exactly the same i only changed the name to a new one and it was able to read the parameters perfectly.

I hope this helps someone in the future.