Cannot open the project after crash

Dear Developers Team

Today I had worked on the project, and at one moment it is crashed. No error messages were shown, it just disappeared from my screen.
After that, I tyred to open the project again, but with no result. Every time when I’m trying to open it, it is loading until 9x%, and just disappears from my screen.

Just before it crashed, I saved my work. It is crashed when I tried to compile it.

I want to know, is there some another possibility to open it?

The crash log is attached.

Thank you in advance for the help.

I have replaced Map file with new one (empty map), to prevent all actors from loading to the map. And in this case Unreal Engine is loading, but anyway, when I’m trying to open last changed actor (before crash) the Unreal Engine is crashing.
I hope that my experience will help to improve the Engine in next versions.
I think that the problem is because I added Capsule Component to the Mother actor with the same name of the Capsule Component in Child actor. The child actors Capsule had automatically renamed, but I think that there is some glitch.
And one more thing - There are many of child actors that have the same Capsula Componene. Maybe this is causing the problem.

I would post this on the Answerhub.
So that the people who can help you see it.

Thank you very much!

You know, I think that the best way to prevent this problem forever is just put some ability to run the project without compile and checking even one of the class.
It would be the best way is to run the engine with specific command line argument, like “-nocheck”.
The main reason that is preventing the project from running is that some class have a critical error, and when Unreal Engine opening and checking the class, it crashes all the engine.
From time to time people are able to fix the problem that is crashing engine, but they just can’t access the code.
I had the same problem for more than 10 times, and my friend has it more than 30 times. And every time it forces us to return to our last copied our to backup archive version with the loss of all the work before last archiving.
I understand that the development team is working very hard to fix all the bugs, and also many of the problems that we have is just because we are writing the code with unexpected errors.
I think that is very many people will say big thank if there will be some ability to run the engine in mode “-nocheck”.

Was you’re issue resolved?

No, I just lost one day of work and returned to my last backup of the project.
It’s not a tragedy, but only because I have a tradition to backup my work every day by copying all the project files to another folder. But if any other guy has no such a tradition, he may lose all the work.
I hope that developers will add the function that I described in post #3, and we all will breathe clearly)

It’s happened much less lately but I used to have this issue ALL the time. Your blueprints do get backed up every so often, there’s a folder in your project that contains them so you should be able to check there and possibly restore that way.

I do think that fundamentally something is wrong with UE4 architecturally when it is possible to put a blueprint in a state that can cause it to be so corrupted that you can’t even open it. If blueprint is to be a drop-in replacement for traditional scripting languages then that aspect really needs fixed. A scenario where it is possible to render a text document unopenable by typing the wrong string of characters into it from within a text editor wouldn’t be acceptable, but the equivalent issue is completely possible with blueprint.

After 4 years this problem is still there. Is there a way to make a project NOT save in a corrupted state where you can’t open your project anymore?