Download

cannot open source file .generated.h

Hi,
I am following this tutorial for how to enter vehicles https://www.youtube.com/watch?v=_U-kSuKScGU&t=376s but I am unable to compile due to a problem from the generated.h files

here’s a screenshot of the affected code, I’m not sure why i’m getting this considering the guy in the tutorial didn’t unless there has been some engine change, any help would be appreciated.

I’ve just started seeing the same error with UE 4.20 final build and VS 2017 running on Windows 10. I created a new, clean C++ side scroller project with no starter assets and it worked fine until I added a new C++ class from the editor. Now, the C++ solution file shows 89 errors. Deleting the <Project>.vs, Binaries, Intermediate and Saved folders resolves the issue temporarily until the next C++ class is added from the editor. Seems to me there’s a new bug in UE 4.20 which is causing this behavior.

This is a new bug introduced in 4.20. There are some topics here in the forum discussing this, as well as answerhub questions. I’ve already submitted a bug report.
Look at 4.20 C++ transition guide by Rama and look at the replies to find a temporary workaround.

Current issue with 4.20, not very easy to work around. Slated for fix in 4.20.2

Turn off Intellisense. Those aren’t actually build errors, Intellisense is just garbage in VS2017.