Cannot open saved Level (Resolved)

So as title says, I’ve got a save and load system that gets the level name on BeginPlay in CharacterBP as pictured below:

And the following is my load game setup:

The issue is that load game calls repeatedly as if it’s on EventTick (I put a print to debug) and I’ve checked references to load game everywhere. It’s not being called externally.

I did find however, that if I remove the ‘open level’ node in the loadgame blueprint, everything loads once. So I tried to make a new ‘loadgame’ function to see if it was something else (It wasn’t). When that didn’t work, I tried an ‘isset’ function on begin play to see if save data exists for saved level. So instead of opening level from load game, I tried to open level from the main characterBP. As soon as ‘OpenLevel’ is introduced, everything in load game starts being called every second or so.

If required I can provide more screenshots.

Can anyone help? I’m really lost here and would like to figure out why it isn’t working.

I see a loop. If the save game is not valid, the load function call itself again. That can’t be right, because it doesn’t have any more info than before…

How many players are you spawning?

Hi, Thank you for responding. Yeah someone helped point out the looping… That said.

Issue is resolved. For those of you that ever happen to come across this issue, I was setting beginplay to load the game, which would open level, which opens begin play etc…

Removing open level logic from character blueprint and storing it in game menu works (Just remember if you set input mode to UI in menu you need to adjust this for in-game).