Cannot open project from launcher but can open from Visual Studio

I was working on my project, added a static mesh component to one of my classes but forgot to initialize it in the constructor, so I got an error, fixed it, but still couldn’t open my project, so I tried opening it from Visual Studio and it worked. I later commented out all the code pertaining to the mesh, but it still doesn’t open unless I do it from VS. Here is the crash report.

Unknown exception - code 00000001 (first/second  not available)

Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.5\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 2026] 
ObjectProperty //Script/MyProject.Thing:ThingMesh must be initialized in the cons

KERNELBASE + 24684 bytes
UE4Editor_Core + 3174852 bytes
UE4Editor_Core + 1677215 bytes
UE4Editor_CoreUObject + 1272350 bytes
UE4Editor_CoreUObject + 382221 bytes
UE4Editor_CoreUObject + 1547437 bytes
UE4Editor_CoreUObject + 1441842 bytes
UE4Editor_CoreUObject + 411962 bytes
UE4Editor_Core + 493152 bytes
UE4Editor_Core + 2188892 bytes
UE4Editor_Projects + 84445 bytes
UE4Editor_Projects + 85014 bytes
UE4Editor!FEngineLoop::LoadStartupModules() + 71 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:1754]
UE4Editor!FEngineLoop::PreInit() + 9213 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launchengineloop.cpp:1310]
UE4Editor!GuardedMain() + 236 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\launch.cpp:112]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.5\engine\source\runtime\launch\private\windows\launchwindows.cpp:201]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Solved the issue by cloning my project. The original still wont open but the clone will.

Hi greennewt,

Would you be able to provide some additional information about the original issue?

  • What version of the Engine are you using?
  • Are you using the binary version installed by the Launcher, or did you build the Engine from source code?
  • Did you try doing a clean rebuild of the project in Visual Studio after adding the appropriate code in the class constructor?

I am using 4.5.1 and am using the version installed by the launcher. I did try doing a clean rebuild but it still didn’t work.

I was able to reproduce the crash that you described. However, the good news is that due to changes coming in future versions of the Engine, this should no longer be a problem. I tried causing a similar crash in our latest internal build of the Engine and was unsuccessful.