Cannot Open Project (Corrupt?)

I’m having a rather terrifying issue with my game project.

Whilst changing constraints on a Physics Asset (Tongue) to attempt to fix an issue (described [HERE][1]) I pressed “simulate” to see how the changes would effect the physics simulation.

This is when the engine crashed. Since this has happened, I can no longer open this project. I instantly get a crash report every single time.

Crash report


Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: !bRegistered || AttachParent->AttachChildren.Contains(this) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.2\Engine\Source\Runtime\Engine\Private\SceneComponent.cpp] [Line: 789]
Attempt to detach SceneComponent 'Tongue'

KERNELBASE + 23544 bytes
UE4Editor_Core + 2998748 bytes
UE4Editor_Core + 1620298 bytes
UE4Editor_Core + 1561376 bytes
UE4Editor_Engine + 6390922 bytes
UE4Editor_Engine + 14507806 bytes
UE4Editor_Engine + 7493574 bytes
UE4Editor_Engine + 7457155 bytes
UE4Editor_Engine + 7366252 bytes
UE4Editor_Engine + 1654141 bytes
UE4Editor_Engine + 1774453 bytes
UE4Editor_Engine + 1772406 bytes
UE4Editor_Engine + 5069785 bytes
UE4Editor_Engine + 9282800 bytes
UE4Editor_UnrealEd + 5084170 bytes
UE4Editor_UnrealEd + 5194890 bytes
UE4Editor_UnrealEd + 2194818 bytes
UE4Editor_UnrealEd + 2363006 bytes
UE4Editor_UnrealEd + 2310925 bytes
UE4Editor_UnrealEd + 2238689 bytes
UE4Editor_UnrealEd + 5160192 bytes
UE4Editor_UnrealEd + 2710037 bytes
UE4Editor_UnrealEd + 2709071 bytes
UE4Editor_UnrealEd + 5306079 bytes
UE4Editor_UnrealEd + 5156619 bytes
UE4Editor!GuardedMain() + 285 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\launch.cpp:124]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.2\engine\source\runtime\launch\private\windows\launchwindows.cpp:207]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

This is a 4.2.1 project. I have also tried cloning it, as well as opening a copy in 4.3. The really strange thing is, when opening a copy in 4.3, I get the following disk error:


Disk F is actually part of my multimedia card reader - which is not in use most of the time. It should certainly have no use for Unreal Engine, since I use it purely for my DSLR card.

I’ve spent a good few months working on this and I’m extremely worried. Any help would be greatly appreciated.

Hey, Kenomica, can you try again with your disk error image? It’s not displaying for me.

Thanks for the reply. Currently I can’t edit the question since it appears Answerhub is having isues.

It’s basically an error box saying

There is no disk in the drive. Please insert disk into drive F:

[cancel] [try again] [continue]

Hey, Kenomica!

The thought just occurred to me to suggest this: Have you checked your backups? Unreal saves backups of your projects periodically. You might have a backup that still works!

Mine are stored at: C:\Users\Jonathan\Documents\Unreal Projects

Fingers crossed,


Just checked and the folder is completely empty, sadly. I assume this is because I had moved the project to a different folder when formatting my PC?

Thanks for the tip though.

Ah, crap. Have you tried searching your computer for “Unreal Projects”? It might still be in there somewhere.

Alright, so we’re escalating this to someone higher up the line. So!

First, we’re gonna need your .LOG and .DMP files from your [project]\Saved\Logs folder.
Second, we need your CrashReportClient.log file from C:\Program Files\Unreal Engine\4.0\Engine\Programs\CrashReportClient\Saved\Logs .
Finally, if you could pass along your dxdiag, we should have enough information to write our report and get this information to someone who can hopefully sort this all out for you.

Hopefully we can finally get this fixed and go back to worrying about the tongue.

Thanks for the continued support. I’ve attached the requested files below. Let me know if you need anything else.

Log Files

Okay, I’m trying to get that moved along over here.

In the meantime, are you sure it’s the tongue that’s causing the crash? If so, you could probably move the tongue’s uasset out of the project, which should let you open it up and get back to work. If it’s not your tongue, that makes things a bit harder.

Ah, also: If the project crashes every time you open it, that could be because it’s automatically opening the ‘broken’ level, even if the other levels work fine.
If you have any levels other than the one that broke, then you should be able to open one of those to work on (while we work on getting the broken level up and running).
You would do that by changing the DefaultEngine.ini file under UE4/[ProjectName]/Config .

Aha! Brilliant advice. I removed the three tongue uassets (Mesh, Skeleton and Physics Asset) and the project opened perfectly, with an error saying those files were not found, of course.

What a relief! I was getting pretty worried!

Hopefully we have a fix coming for the thing that happened to the tongue, but at least you can work again. I’ll mark this as ‘Resolved’ for now, but feel free to let me know if you have any other troubles!

I suggest creating a new project and copy all the configurations under config folder and replace the config files of your current project