Cannot modify transform of blueprint actor?

Hello there,

I have a weird problem. For some reason I cannot move, rotate or scale any component in any blueprint. I can enter numbers in the details panel but they don’t apply when I place the blueprint in the level. It doesn’t matter what I change below “Collision”, my actor just falls through any floor. I selected it to “BlockAll”. Is it just me doing a mistake or is it a bug or configuration? I can’t work any further because of this.

I hope somebody has a solution for this.

Thank you!

I notice that too and also notice that it only for root component, what is interesting i actually can change transformation of root component thru C++ but i do that before assigning it as root component. So it looks like some kind of bug, if not it was prevented for some specific reason.

Whatever it is a bug or not, quick workaround for now is to not make component you what to transform a root component, if this is only component then put some billboard component as root component which is not rendered for players

Seems only to happen sometimes for me. Glad I am not the only one having this bug and hope it gets fixed soon!

As far as I understood, the root component cannot be transformed and this is done by design!
It is always in origin with no scaling and rotation. The transformation applied to the component root node is just the placement of the actor (blueprint) in the world scene.

As Shadowwriter suggested the standard solution is to use an Arrow or Scene “dummy” root node in the blueprint component editor (via Add Component) and the mesh/light/whatever you need to apply a local transformation on is added as a child of the root Arrow/Scene component. Then the transformation on your mesh/light/… will work.

Regarding the “collision not working” question. Make sure both objects you want to collide have collision mesh/bounding box. It’s a known bug that if you create a static mesh from a brush the static mesh has no collision mesh generated automatically and you need to do it manually in the static mesh editor.

I try to do what you said but the problem is that the actor only records collisions from the root so if i put a scene as the root it doesn’t collide with any thing

I don’t know if this make help in your case (especially after eight years :smiley: , but maybe for descendants ). But i faced the same problem and in my case solution lies in Construction Script. If you have there SetLocationAndRotation node (or something like that), you’ll need to manipulate with her, or simply disable

1 Like