Cannot login to Source Control in OS X Editor

My studio uses Subversion (SVN version 1.8.10) for our Source Control solution. We’re using version 4.6.1 of Editor. On Windows, everything works great. But, in OS X Editor, it will not login to Source Control.

I enter all of credentials (which I’ve double and triple-checked) in Source Control Login window, and then click Accept Settings, but nothing happens; windows stays open, with three pulsing blips, and it will stay that way indefinitely (I’ve left it open for over an hour; nothing).

This is a huge issue for us, as this means we’ll have to resort to manually locking files we’re working on through a separate SVN client, instead of Editor checking out files for us. Any help would be greatly appreciated.

I’ve spent several hours investigating this; here’s what I’ve turned up so far:

  • If I try to check out a working copy from online repository under SVN 1.7.x, Unreal Editor says it can’t use it because it requires a working copy made with 1.8.9
  • After Force Quitting Editor (since it’s stuck trying to connect to repository), Connect to Source Control icon is Yellow in color, and mousing over it says that Source Control is Enabled
  • When clicking on icon, url, user name, and Labels directory settings are saved, but Password is not
  • There is a warning: Warning Successfully connected to repository [redacted]
  • And an error: Error svn: E215004: Authentication failed and interactive prompting is disabled; see the --force-interactive option
    svn: E215004: Unable to connect to a repository at URL ‘[redacted]’
    svn: E215004: No more credentials or we tried too many times.
    Authentication failed
  • I have run Terminal instructions found here: Using SVN as Source Control for Unreal Engine | Unreal Engine 5.1 Documentation
  • When running Terminal commands mentioned at link, I did receive an “Error validating server certificate” error, and accepted certificate permanently
  • Even after doing Terminal commands, and accepting certificate, issue persisted
  • After opening Editor again, there was a warning in Source Control login window: “Warning Successfully connected to repository [redacted]”
  • There was also an error: Error svn: E215004: Authentication failed and interactive prompting is disabled; see the --force-interactive option
    svn: E215004: Unable to connect to a repository at URL ‘[redacted]’
    svn: E215004: No more credentials or we tried too many times.
    Authentication failed

Thanks for extensive information - we will investigate issue!

For reference, issue number is UE-9429.

Is there an update on progress on this issue? It appears to still be present in 4.7.5: SVN on OSX 10.10 hangs forever, works manually from cli - Programming & Scripting - Epic Developer Community Forums

Thanks! I’ll give that a try next time I can and will comment back when I find out what happens.

Try removing all trailing slashes from repository and labels directory fields & try again. I can login successfully (on Mac) to an SVN server on CloudForge when I don’t have trailing slashes & it fails if I add them with errors being described here.

If it doesn’t work, try running an svn info request on Terminal:

/Path/To/UE4/Engine/Binaries/ThirdParty/svn/Mac/bin/svn info --username=your_username https://path/to/repository

Replacing /Path/To/UE4 with actual path to your UE4 Engine directory, your_username with your SVN login & path/to/repository with actual path to SVN repo.

This should prompt you to enter your password, or authorise SVN to access keychain for it, in which case click Always Allow. If you’ve already denied svn access to Keychain, then you’ll need to input your password each time you connect via UE4.

Any updates on this issue?

Not a direct solution, but my studio has been using Versions on OS X. It isn’t integrated into Editor, and you have to remember to add new files; but it works really well otherwise. I’d recommend checking it out:

happening in 4.8.1 for me, completely frustrated, especially when I looked on here and saw how long this issue has been around

Hi all,

No real update on this issue yet, however it does have a goal set of 4.9 so hopefully we’ll see a fix soon. I’ve updated community interested on bug report as well.

Thanks for response. It’ll be nice to have this fixed for 4.9.

Alas. This is still broken in 4.9:

Same issue as above using new client. get authentication error

Hey - let’s see if we can deduce what’s happening with 4.9 build. As of 4.9 we pick up system svn version to use, before falling back to our pre-built binary that’s shipped with UE4.

Here’s a couple of things to try and report back on:

  1. What path is being reported for svn operations in UE4 log? You should see a log message on startup along lines of “Using path /bin/svn for svn operations”

  2. Please try running additional set up commands mentioned in this article with but instead of cd-ing into engine directory, use directory reported in step 1.

  3. If it’s still using version we ship with UE4, try overriding it to use your system version, if you have one installed (add ExecutableLocation=/path/to/svn to [SubversionSourceControl.SubversionSourceControlSettings] in SourceControlSettings.ini), then repeat step 2.

Let us know if you get any mileage with any of these options

Yikes – this bug is a doozy. I have spent hours trying to figure out what’s going on, to no avail. My last attempt to fix it involved deleting working copy and checking it out using exact same SVN binary that ships with UE4. (I heard UE4 is “picky” about what version of SVN is used to check out a project.) Unfortunately, this did not solve problem.)

It’s really a shame, because this makes Mac version of UE4 a tough sell for projects versioned by SVN. In my experience, relying on external version control for UE4 is super dangerous unless you’re very, very careful about what files you commit or don’t commit. Accidentally committing wrong files can lead to corruption and general weirdness.

Hey TheoTowers-

Could you try suggestions mentioned by Andrew Rodham in his previous post and let us know if you’re still having any issues?

4.11 - I still cannot get Subversion / SVN work with OSX.
Windows no problem…

Hello Frtisl,

bug report for this issue is marked as fixed as of 4.9’s release. If you’re still experiencing these issues, could you provide information that AndrewR had asked for in his previous comment? We can look into if issue is still happening and get it reopened or enter a new bug report to get it fixed.