Download

Cannot launch & package for iOS device

The certificate and provisioning profile are both valid in Xcode. But it always failed to launch or package for iOS device in Unreal editor. I ever met the same issue several times before.
And I fixed the issue before by updating Xcode or Unreal. I cannot find any other methods to resolve the issue. And the launching log is as below:

LogPlayLevel: DeploymentServer: Failed to connect to bundle ‘com.xxx.xxxxxx’ with Unknown error 0xE80000B7

It’s very painful to develop Unreal game on iOS. :frowning:
Who can help me? Many thanks!

Best Regards.

Tiger Y

I did launching & packaging on Xcode 8.3 & 8.3.3, and UE 4.15.3 & 4.16.3. The tests all failed. :frowning:

Unity can also launch & package successfully with same provisioning profile, certificate. It is different from Unreal, unity creates iOS project then launch & package in Xcode.

Ran into the exact same issue today. And yep, my provisioning profile / cert works from both Unity and Xcode.

The error I get is that the provisioning profile and cert cannot be found. This is in the dev-ar-kit branch. Seriously painful…

I can get Ar branch to work and launch but nothing else :frowning:

were you able to launch?
i have been trying to test ARkit and it does the same for me. can not connect to bundle.
please help if you figured it out.

same issue but I cannot solve either

Please, see my answer to this post. It may help you.

https://forums.unrealengine.com/development-discussion/ios-development/1402857-issue-launching-from-windows-to-ios-failed-to-connect-to-bundle-new-to-ue-ios-development

If anyone is still having issues launching your iOS game on your device, you can try the following:

  1. Use the “IPhonePackager.exe” only to generate the “Certificate Signing Request” (It seems that after UE4.5 Epic deprecated its usage)
  • If you really want to use “IPhonePackager.exe”, you have to download a file called “UE4Game-Info.plist” from the 4.6 branch of UE4 in github and place it in your UE4 installation directory under: “UnrealEngine/Engine/Build/IOS/”. If you don’t do so, you will get errors on the IPhonePackager console.
  1. Remove all obsolete provisioning profiles from your project - Remove obsolete mobileprovision profiles
  2. Remove all your certificates from your project (not quite sure how I did that, because it was a while ago)
  3. Reboot your PC and verify that you don’t have any provisioning profiles or certificates in your iOS settings of your UE4 project
  4. Go to your apple developer console and remove all Certificates, Identifiers and Profiles
  5. Follow the official iOS provisioning guide from Epic
  • Important information about the identifiers step:

    My **identifier** in the apple console is using a wildcard and it is: **com.mycompany.***
    The **bundle identifier** in iOS project settings is: **com.mycompany.mygame**
    
  1. My certificate did not work right away. I had to wait for a few hours
  2. I was not able to launch the game on my iOS device, so I had to first package it and upload the .IPA file to my iPhone via “IPhonePackager.exe” Advanced Tools Tab.