Download

Cannot launch and make GearVR package in 4.20.1 engine version

Hi, I have a project in the 4.19.2 and it works fine. But if I try to switch to the 4.20.1 version I got new errors. I make the project for the mobile GearVR. My error:

LogPlayLevel: AARImports: com.google.android.gms, play-services-plus, 11.8.0
LogPlayLevel: ====8/15/2018 6:11:04 PM====PREPARING NATIVE CODE=================================================================
LogPlayLevel: APK contains data.
LogPlayLevel: ==== Writing new GameActivity.java file to C:\Users\Dima\Desktop\GearVRMCTouchpadInpu19.2ArrOld\GearVRMCTouchpadInpu4.20Jag\Intermediate/Android/APK\src\com\epicgames\ue4\GameActivity.java ====
LogPlayLevel: ERROR: Can’t make an APK without the compiled .so [C:\Users\Dima\Desktop\GearVRMCTouchpadInpu19.2ArrOld\GearVRMCTouchpadInpu4.20Jag\Binaries\Android\GearVRMCTPInput-armv7-es2.so]
LogPlayLevel: (see C:\Users\Dima\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+UE4+UE_4.20\Log.txt for full exception trace)
LogPlayLevel: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 14.764260
LogPlayLevel: BUILD FAILED
PackagingResults: Error: Launch failed! Unknown Error

Also, I launch and package the project in the 4.20.1 and its the same error in the GearVR. But in another default 4.20.2 project its works. Also in the older version 4.19.2 all works…
If someone knows how to fix this please write the answer.

Perhaps try deleting the intermediate and binaries subfolders in your project? Sometimes needed after migrating your project to a new engine version

I tried but not helped, but I switched the project from 4.17. I try to make the new project and launch it. Hope it helps, or that is Android SDK. Thanks

Made sure your codeworks is up to date?:

\Engine\Extras\AndroidWorks\Win64

I see you experience the same error I have which I described in this post today. Something changed/broke in 4.20.2 for existing projects?