Download

Cannot Install Unreal5 - Installation Fail Specify Shorter Location

No one is answering me so going to start trying things on my own. Things I’m trying:

  1. Updating Visual Studio to latest 2017
  2. Uninstalling all old versions of Unreal and all projects.
  3. Changed vid from unlisted to public & provided link description to this forum.
  4. Uninstall Epic Launcher
  5. Uninstall Bridge
  6. Delete folder with Epic Quixel and Megascans (don’t know how to uninstall megascans)

Reinstall everything to C drive avoiding Program Folder where got this kind of problem first time I installed Unreal 4.

Uninstalled and deleted all folders on my computer to do with Unreal.

At last second changed my mind and tried installing it to the suggest path of Program Folder. Had this issue before Windows claiming Unreal was virus problems BECAUSE put in Program Folder. Why I was doing C:

But this time did Programs Folder and only installing Unreal5 no other version of Unreal. Seems to have worked so far.

There is a Windows 10 virus accept popup no one talks about that asks if you want to make this all private or public. Last time chose tick both boxes (sorry didn’t think take pic of it) this time just the recommend one already ticked private box.

Got that popup again recently for no reason just opened Epic and there is it again:

I see you are using Visual Studio 2017. The message is two things. Change the name to UE50EA from the massively long file name from UnrealEngine-5.0.0-early-access-1.
setup.bat will fail as it expects VS 2019 and come up with the error about path length at 99% of Checking dependencies.
See Release notes
Quote

Once you have the source, building UE5 Early Access is exactly the same as UE4. For details, see the most recent UE4 documentation. The only difference is that Visual Studio 2015 and 2017 are no longer supported. You must use Visual Studio 2019 (v16.4 or greater).

Mine builds without error on the latest VS 2019 (v16.10.1)

Okay I’ll search for the VisualStudio2019. Not a complaint to you at Unreal. But tell you how I am behind times confused got where I am. The installer told me 2017 says not a word about 2019. Just some small print blab in the corner about a newsfeed I overlooked did not think about it. Cause how would I know?


Also note my problem with not getting files to associate cleared up even tho I am VisStu2017 still as I tried to create another project and save-exit Unreal5 said, “not associated files do you want to associate” and I said “yes” so now my files are working:

Now I can make a nice file on the Desktop.

But didn’t Unreal4 let you make a direct project file via the Library right clicking project? And that option is now gone? Mmmgonna look real quick.

Says “show in explorer” which gets you there with one extra step. In Unreal4 we had option to create the project desktop icon when right click. I am being nitpicky. It is not important def not a bug.

Unreal5 opens faster than Unreal4 did this alone is weight in gold.

THANK YOU. I HAVE NO MORE PROBLEMS AT THIS TIME.

Can we mark threads solved? Don’t think I can edit my first post.

When you have UE5 project running, on the taskbar RIGHT click the UE icon.
The second option is “Pin to Task Bar”. So now when you finished with the UE Editor and Exit you can quickly start up by clicking on the pinned UE icon. You will need one for each project and you CANNOT rename the icon. UE5 is so much faster. Background Shader building with a progress meter is my favourite

Once you have the source, building UE5 Early Access is exactly the same as UE4. For details, see the most recent UE4 documentation. The only difference is that Visual Studio 2015 and 2017 are no longer supported. You must use Visual Studio 2019 (v16.4 or greater).

VS 2017 and 2019 using different installers. The latest one can be obtained here: