Cannot get tank turret to rotate

I’m following the Blueprint Creating a Tank | Live Training | Unreal Engine - YouTube tutorial and he unfortunately tends to gloss over a lot of things. I also understand that this is in UE4, and if this is a simple version issue, that would make total sense.

I followed his instructions for moving the tank, which worked fine. And the setup for the turret looked rather similar, but he does not actually make it for the video, so it is hard to tell if all the specifics are right. Despite replicating it identically as far as I can tell, it didn’t end up doing anything. Whenever I move my mouse, nothing happens. I also tried binding the turret rotation to the arrow keys as well, but that didn’t make a difference.

image

Here is my event graph for the turret rotation. The relevant part of the tutorial is at 14:52. I’ve double checked and cannot seem to find a difference.

Just as in the tutorial I’m using static meshes. I made them myself using Fusion 360 to create the solids then Blender to add sockets and convert to FBX. That caused some scale/rotation issues when I assembled in UE5 because I wasn’t attentive to some details in Blender, but I don’t see how that would impact this.

Are you sure Turret speed and pivot speed isn’t 0?

Well I feel very stupid. Thanks lmao

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.