Download

Cannot Get My Mod To Cook Properly

I cooked a mod or two and no problems, but the latest one I’m trying to cook just won’t cook the assets. The only stuff in the ModTools/Output/Mod folder are:

mod.info
modmeta.info
LinuxNoEditor/mod.info
LinuxNoEditor/modmeta.info
LinuxNoEditor/Roof.umap.z
LinuxNoEditor/Roof.umap.z.uncompressed_size
WindowsNoEditor/mod.info
WindowsNoEditor/modmeta.info
WindowsNoEditor/Roof.umap.z
WindowsNoEditor/Roof.umap.z.uncompressed_size

I read that you shouldn’t copy over from other mod folders, and so I tried making a new mod and copying over only the primalgamedata, etc. directly from the game files instead of the ‘GenericMod’ folder. I copied over my static/destructible meshes, Icons, structure blueprints, engram blueprints, primal Item blueprints, and re-linked everything, and still get the same thing when cooking. I worked at this problem a few hours last night, and a couple hours this morning trying various things, and I’m at a loss.

Here is a link to my uncooked mod if someone would be kind enough to help me out and have a look: https://www.dropbox.com/sh/wj44ta6rfj2bthq/AACMWomL57QDFDJU6Yrw25PDa?dl=0

Hey MechanizedIT,

Sorry to hear you are having problems!

Alright, so I’ve got something I would like you to try if you don’t mind. I had this same problem weeks ago with my mod, and have a few suggestions on things to attempt to see if it fixes it for you.

  1. Can you try renaming the mod folder you are trying to cook to a different name? (back up the folder first just in case, so you do not chance losing your progress on your mod) Then try cooking and report back. If that does work, then just rename the mod folder back to the original name and try cooking again.

  2. If step one does not work, can you try moving your entire mod folder’s contents from inside of the ADK to another folder and then back to the mod folder again? This might take a while for it to rename/move everything, but I recall renaming/moving to be the trick that got things to cook out for me again.

Let me know if these do not resolve your issue, and I’ll go back to the drawing board/try to recall if there was anything else I tried.

Step 1 has not worked. With Step 2, do you mean move the contents to another folder in the ‘Game’ folder inside of the ADK, or move it to like a folder on my desktop?

Move it to another game folder temporarily and then move it back (again back it up before hand just in case).

Ok, so that hasn’t worked either. I’ve got to go for now, will try out some more stuff later. Thanks for the help Sinarisinestro

No problem good sir! Sorry we couldn’t get it resolved right now :confused:

PM me when you have some time and lets try to coordinate a troubleshooting session. I’d like to get more info later when you have the time, and hopefully be able to help you get this figured out and fixed ASAP.

Are you doing TC i cannot get TC to cook does just this no idea why?

Hello, Survivors…This may be obvious and stupid, but had me stumped with the same problem for a good long time. Turns out I copied all 3 files from generic mod renamed and modified them correctly. Got the mod to work in the editor but tried and tried and tried to upload and use in game with no luck. I saw your post and checked my files to see they were all 1k except the icon…Doh!..Turns out I had a typo on the cook dialog where I put an extra space in the name of my map. After 4 hours of checking every file and repeatedly loading boy I felt retarded. Summary…Check your map name spelling :wink:

Thanks for trying to help guys. I did look at all my naming, my icon sizes, what everything was referencing etc. and never could get it to cook, then i upgraded to 200.5 and started over with the mod and have been successful cooking this time around.

I’m just learning to mod Ark like a lot of other people and this is more of a test mod for me. If you’ve looked at the files you’ll see its just a structure variant which adds a sloped wall (triangle) and adds a new ramp that is a different angle than the original one so that it fits with the new sloped wall for making nice sloped roofs without big gaping holes in the wall.

Everything seems to be working now except that when the structures are destroyed they don’t fracture, they fall down as one piece. I have the destructible meshes in and seem to be setup the same way all the other destructible meshes in the game are setup, and they are referenced in the structure blueprints, and they fracture when I test them in the destructible mesh editor. So I don’t know, maybe someone could help me figure that one out.

Also, Since I am making a triangled wall, I need to make an inverse one, is there a way to do that without adding a separate engram and structure for that, so that according to the players perspective and snapping it will invert the structure?

Thanks again for all the help guys.

Mechanized, you should be able to change the structure placement by editing the snap points. These can be quite tricky and will take a bit of time, but if you get them set just right, they will definitely make everything look very smoothe.

Im experiencing same problem as the OP (nothing gone right for me since switch to EG launcher xD)

I tried both of these steps, and also tried redownloading the entire Dev Kit again last night but it still doesnt seem to cook right. It looks as if its cooking properly if i use the ADK to cook it? but when i try to upload i get the Error: Cant find file… message

I just tested this, taking a new copy of Generic PrimalGameData, TestGameMode & Level into my mod, linking them up but not referencing anything and got the same result. So i dont think its a typo or anything like that either :confused:

Hey Bacon, did you make sure to open the level, go to world settings, and reference your mods primal game data and then save the level? I know this is a simple step, but I think this may be something i forgot to do in the first case, although I can’t imagine I didn’t.

I have. My mod was working for weeks before it suddenly stopped - but Ive doubled, triple and quadruple checked this step :slight_smile:

I’m having the same problem… I tried all of these steps. Is there something special I need todo when copping over the blueprints to my mod folder? I just copied them then renamed with a _RAWR at the end. Should I not rename blueprints?